Hostname changing when connected to mobile tethering

Usually when I am connected to home wifi, the hostname is just “fedora”. When I connect my laptop to my phone’s mobile tethering, the hostname changes so that I see [jlee@node-blahblah..~]$ in the terminal. Same happens when I type hostname command.

Is this behavior normal?
Thank you.

Your mobile phones internet provider is altering the hostname of your device. This usually happens when you connect your device to a Wifi host where the router is setting your hostname according to the DHCP setting. Since you do not have access to your internet providers DHCP settings, you can just set a static hostname to your laptop so it wont change.

#hostnamectl set-hostname host_name --static

1 Like

Thank you so much !