Unable to install firmware update?

Whenever I start up Fedora, GNOME Software shows that I have an update for my T14s Gen 2’s firmware from 0.0.9 to 0.1.13. I found a similar post made before but the solution isn’t apparent.

In case it matters, my laptop is dual booted with Windows 10 and Fedora 35 encrypted with LUKS. I notice when booting up my computer there are now two Fedora options that are nearly identical in name. I haven’t booted into the new installation since I’m not sure what it would do, but I thought it was worth mentioning.

Can you please show us the output of the terminal command

sudo dnf update

Fedora 35 - x86_64 - Updates 17 kB/s | 11 kB 00:00
Fedora Modular 35 - x86_64 - Updates 33 kB/s | 11 kB 00:00
Dependencies resolved.
Nothing to do.

It looks like there’s nothing to update from the terminal, but GNOME Software shows I have out of date firmware.

This you did give a try?


I did try running those commands. It looks like the firmware updates, but once I reboot the updates did not apply.

There is one small update though. As I mentioned earlier, since getting Fedora up and running for the first time I now get two options for booting into Fedora when starting up my computer.

Fedora Linux (5.14.10-200.fc35.x86_64) 35 (Workstation Edition)


Fedora Linux (5.14.10-300.fc35.x86_64) 35 (Workstation Edition)

I finally tried booting into the second option to see if that would work, but everything remains the same.

Try to install sudo dnf install gnome-firmware.

If there any newest firmware that applicable to upgrade on your device, it will show a button to upgrade.

1 Like

Just installed gnome-firmware. I don’t see any buttons popping up but when I open the firmware application, it says there are updates that need to be applied.

Do you have SecureBoot enabled?

Looks like these bugs:

I’m also waiting for a resolution.

1 Like

This is mine:

If I’m not mistaken, vendor of your hardware need to push an update to https://fwupd.org/ to make user be able to update their firmware. If they (vendor) didn’t push the update, it will not available for user.

If it related to bios (including uefi firmware), may be you could find the windows version and update it from there.

I do! Perhaps there’s a bug that’s causing it.
If I disable secure boot, do you think I might be able to update my firmware?

Another user pointed out these bugs which might also be the cause.

Would you happen to know the process for doing that? It looks like everything is up to date on the windows side of things but maybe I’m missing something.

1 Like

Please read on here. That link for a case the vendor is Dell that provide update from linux.

If your system is listed at https://fwupd.org/lvfs/devicelist, 023168952e27d341c9a2f21c60b38616f2ec817d.jpeg then it supports UEFI capsule updates and can be updated natively within the OS.

You could also find for Lenovo on their official web pages. If they provide update bios for specific to your laptop series, it’s should give the announcement or on how to install it.

Btw, if you already update the bios from Windows, no need to install it again from linux.

It migtht, haven’t tried. The bug seems to indicate that the problem lies in the shim for secureboot.

To update BIOS on my Thinkpad, I do as follow until this bug is resolved:

Make sure it’s the right model: from your indications, I think it’s this one.

  • Make a bootable USB with the file downoladed (I use fedora media writer for this, works like a charm!).

  • Boot into the BIOS-Update-“CD” (USB Stick) (by pressing F12 at start-up) and follow the instructions.


Maybe something similar to what I experienced with my T490s (cf. Thinkpad T490s Intel Management Engine Update No updates to process, called in error, ... · Issue #149 · fwupd/firmware-lenovo · GitHub). The BIOS update was not applied as the Lenovo firmware package wrongly set the boot order. You can check if this is also the case with efibootmgr -v and check the boot order line. The Linux-Firmware-Updater has to be ordered first. You can change the bootorder with the command mentioned in the above post.
If your issue is different, check for similar issues in the above github repo or post a new one there.
All the best.

Also wasn’t able to update the Intel ME with SecureBoot enabled.

Had to disable SecureBoot, then I could update the Intel ME.

I reactivated SecureBoot afterwards.

I really hope this gets solved soon…

So I’m thinking nhnh had the right idea, that this issue was caused by a bug with secure boot. After disabling secure boot, I was able to update the firmware.

I ended up returning the laptop anyways due to other problems but I appreciate everyone who tried to help.


Just found this issue that seems similar.

As I understand this (witch might be wrong), Ubuntu solves the problem with a signed fwupd package. Seems to make sense to be able to load the firmeware updater with SecureBoot enabled.

Could this also be a solution for Fedora?

Edit: I don’t consider disabling SecureBoot to be an appropriate solution (its just the only current workaround I could find): firmware updates should be possible while enjoying the protections provided by SecureBoot.

1 Like

Has there been any word about this, up or downstream. I’m experiencing the same secure-boot issue on my ThinkPad X1 Carbon Gen 9, which “officially” supports Fedora. I know @mattdm also has an X1 carbon, and I’m sure there are others in this forum. Have you all been experiencing this?

I have a Lenovo ThinkPad P14 and fwupdmgr has worked consistently for me with secureboot enabled.

Do you have an encrypted disk?

Also, do you have vPro features enabled?