Unable to create kind cluster on Fedora 36

I tried, as a regular user, to create a kind cluster on Fedora 36 with: kind create cluster
But I get this error:
ERROR: failed to create cluster: running kind with rootless provider requires setting systemd property "Delegate=yes", see https://kind.sigs.k8s.io/docs/user/rootless/
For more details see:

What is the problem here?

Maybe from the link provided in the error …

Create /etc/systemd/system/user@.service.d/delegate.conf with the following content, and then run sudo systemctl daemon-reload:

[Service]
Delegate=yes

You may have to create the directory and file. For instance on my system I don’t have

/etc/systemd/system/user@.service.d/

but do have /etc/systemd/system/user@.service.wants/ which has a user configuration file unresourced.service.

So it would be sudo mkdir /etc/systemd/system/user@.d && cd /etc/systemd/system/user@.d && touch delegate.conf
followed by sudo vim delegate.conf, and add the service with [Service] on the first line and Delegate=yes on the line below.
Save and exit then do the daemon-reload and you should be good to go.

Thanks Stephen, I tried that, but I kept getting the same error. In the end I added my regular user to the dockerroot group to fix it. See this bug report for details. I’m not sure though if that is the correct/best solution. But at least it works now.

I noticed the following:
If I ssh into my local machine with ssh localhost, there is a difference in cgroupControllers info of docker info , compared to when I have a regular terminal session:

$ diff docker_info_ssh_session.txt docker_info_no_ssh_session.txt 
5,7d4
<   - cpuset
<   - cpu
<   - io
45c42

When I’ve ssh-ed into my localhost, I can create a kind cluster with kind create cluster.
What is causing the difference between a ‘direct’ session and an ‘ssh-session’?

Edit: Maybe the above described issue is related to this bug.