Can't start after update

Hi everyone,
Since I updated fedora I can’t start it anymore (actually I can, I just have to select the old kernel at start up)
I thought it was because of material (on macbook air) but I also updated my desktop and had exactly the same problem. after grub menu I got this:
[FAILED] Failed to start rule-based r for Device Events and Files
[FAILED] Failed to start rule-based manager for Device Events and Files
[FAILED] Failed to start rule-based manager for Device Events and Files
[FAILED] Failed to start rule-based manager for Device Events and Files

then after one or 2 mins:
Warning: /dev/disk/by-uuid/f97........55f does not exist
Generationg "/run/initramfs/rdsosreport.txt"

I tried on Virtualbox and same thing after I updated. Here is the grub entry menu not working :
Fedora (5.9.11-200.fc33.x86_64) 33 (Workstation Edition)

on the Desktop I can Ctrl-D or write password but on Laptop it is frozen I have to hard Halt the laptop to restart.

Thanks for your time and patience.


Yeah, I’m seeing more reports like this from various people than normal. I’ll give the kernel team a heads up. Can you give more details about your setup? Are you running VirtualBox on both the desktop and the Mac laptop?

Thank you for your answer. no I am using virtualbox on fedora (fedora on fedora :rofl: ), the system is install on disk on the deskopt , the mac and another lenovo yoga 13. no dual boot, fedora only they all have the same issue.

ps: I just tried on alienware m15 dualboot with windows and samething.

1 Like

So all of these systems don’t work? That’s perplexing, since according to the kernel team they haven’t had widespread reports of problems. Can you think thing of anything special about the configuration that all of these systems might have in common?

Can you try applying this test update to 5.9.12 to see what happens?

sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-04850ab36b
1 Like

Ok, I will test the update.
to answer your question, 2 of them were upgraded from fedora 32 (desktop and lenovo) the only thing they may have in common is the country where I am (repository problem?) but I think when I updated I saw some errors during installations like
ERROR failed to ....
not sure about it. I can reinstall on virtual machine and update again to check it.

Hmm, yeah, those errors would be helpful. Check /var/log/dnf?

1 Like

So I booted on 5.9.12-200 kernel but unfortunatly same issue.
et read all the full /var/log/dnf.log and I didn’t find any error reported. I think I am not crazy I saw those errors.
So I am now reinstalling fedora from LiveUsb erasing everything then I’ll update a check everything in details.
It may take a while.
Unfortunatly at this present moment I only have the macBook air with me as I am not at home. Let assume that macbook doesn’t add other issue related or not.

Ok I installed Fedora 33 on MacBook Air,
the only thing I did was
dnf groupinstall "C Development Tools and Librairies"
dnf update

I add some errors not related to kernel
warnings :
/etc/chrony.conf created as /etc/chrony.conf.rmpnew
The unit file ....drop-ins of mlocate-updatedb.timer change on disk

sssd-autofs.service Operation refused
sssd-nss.service, cups

So i booted on new kernel (the one failing before) 5.9.11-200 problem disappeared, load perfectly

The only thing that is different with before is the kenels, before I had 5.8.xx, 5.9.10, 5.9.11
now I have only 5.8.15 and 5.9.11, so maybe something happend during upgrading from 5.9.10 → 5.9.11.

I don’t know if it is possible to downgrade on other computers from 5.9.10 (lastest working) to 5.8.15 then update directly to 5.9.11 like I just did now?

new update here. I tried to dnf roll back but ofcourse it doesn’t work has I didn’t have my local repository (starting to thing dnf history rollback is not that useful).
dnf history 86
Fortunaly showed me all error I couldn’t find in the dnf.log. all of them are dracut Error or dracut failed.
they are 399 errors I will not paste it here but I noticed some that may explain the problem:

51 dracut: FAILED: /usr/lib/dracut/dracut-install -D /var/tmp/dracut.pWodUt/initramfs -a -l nologin
181 dracut: FAILED: /usr/lib/dracut/dracut-install -D /var/tmp/dracut.pWodUt/initramfs -l /usr/bin/systemd-run
214 dracut: FAILED: /usr/lib/dracut/dracut-install -D /var/tmp/dracut.pWodUt/initramfs -a -l umount
400 dracut: FAILED: /usr/lib/dracut/dracut-install -D /var/tmp/dracut.pWodUt/initramfs -a -l umount poweroff reboot halt losetup stat sleep
Basically everything failed event fsck.* unmount, mount, mv, dmesg, rm, ln, chroot … No wonder why it can’t boot.

I am thinking about trying a manual risky rollback, look at the history to manually uninstall all new packages and manually install all old one assuming I can even find them all.

After googling I got some suggestions that could be update of microcode and today I found

Have you update microcode_ctl ? recently , it is not easy test if it is a microcode problem , also is suggested update BIOS,

Hey thanks for your answer.
I am not sure I want to update a bios for 4 different devices. even thought I wanted it. I will have issue with some like the Apple one.

Have you update microcode_ctl, recently ? Maybe you may just test downgrade microcode .

1 Like

I saw that microcode_ctl is the last version, Ok I’ll try downgrad it. thanks

I did downgrtad it but nothing different.

What filesystem are you using? 5.9.9 - 5.9.10 had some XFS issues, which could definitely create problems, and using them to do an upgrade could be an issue, but that was fixed with 5.9.11. The issue would complain of fs corruption, but there was no actual corruption, so booting back into 5.9.8 or earlier, and then updating to 5.9.11 or newer should work. We are on 5.9.13 now, with 5.9.14 in updates testing. Does this still cause issues with either of these kernels?

I am using ext4 , df -T :
/dev/sda5 ext4 30935964 20062824 9278620 69% /
/dev/sda6 ext4 10255636 49128 9665836 1% /tmp
/dev/sda7 ext4 90286944 63626784 22030812 75% /home
/dev/sda2 vfat 98304 45271 53033 47% /boot/efi

now I am on 5.9.10-200 after update 5.8 was deleted and the new one does the same thing . here are my installed kernels:

I have the exact same problem on a Thinkpad T14 with kernel 5.10.12-200: Failed to start rule-based manager for Device Events and Files, and then it hangs. Is there a fix for this?

I installed F33 from a live usb with kernel 5.8.15-301, and that still boots fine.

Do you have dracut errors in your logs? @jforbes any further thoughts?

In my case, It disappeared after one update and reappeared after another one and so one. Just boot on the working kernel until the next update.
In another laptop I just reinstalled fedora 32 hoping this issue will be gone in F34

I hope so too but I’d rather find and fix the root cause :slight_smile: