Unable to control brightness using keyboard


I have recently installed fedora 34. It is working good but only the issue is I can’t change brightness using keyboard keys. But after sometime I found that I can control the brightness after sleep (suspend). I checked online for the solution but nothing works for me. Given my laptop specification below,

Lenovo Ideapad S145 - 8MV model
Intel chipset, Nvidia MX110 gpu.

Anyone please provide any solution for this issue.
Thanks in advance.

Welcome to ask Fedora @kumaranrv !

Please check also the Lenovo website, they have a Linux section too. Important is also that you have the newest firmware on your Lenovo device.

I tested this command xrandr --output DEVICENAME --brightness 0.5 on my device with 2 displays, and I can adjust both of them via the command-line. You need to adjust the DEVICENAME name.
To get your connected devices, you can run: xrandr --prop | grep " connected"

After that it would be possible to create a keybinding. Unfortunately, there seems not to be a simple solution to increase or decrease the value stepwise.

You could run a command at system-start to set the brightness to a fixed value. Just thought of as an idea. For running a command on system start, there a many options, for example one may want to use the GNOME Tweak Tool.

EDIT: There seems to be a solution via the tool brightnessctl to increase/decrease stepwise. I’m pretty sure that my solution is not the best available, so please first try to update your system or query again for a better solution.

I checked ‘brightnessctl’ command it works, the issue is after revoked from ‘sleep’ mode I can change brightness via keyboard, but when I restarted it doesn’t work, how come this would happen.