Unable to connect to Wifi Hotspot

I am having an issue connecting to the WiFi hotspot that I have crated on my Fedora 32 workstation laptop. I was dual booting Windows/Kubuntu and the hotspot was working in both OS’s on this same machine. I am now dual booting Windows/Fedora (Gnome 3), the hotspot still works in Windows.

I am able to create a hotspot with both nmcli and the gui, but when I try to connect to the hotspot the connection fails with a “Failed to obtain IP address” on both Android and my Nintendo Switch.

I tried changing the available IP addresses with nmcli and nm-connection-editor, but I am unable to get the connection to work.

If I connect with a static IP address from Android I am able to get connected to the hotspot, but then I get a “network connection not available” error, and I am unable to access the internet. If I change the Android phone back to DHCP then the phone gets disconnected.

I have spent ~3 hours searching for the answer, not sure what I am missing. Thank you very much for your time!!!

Hi @brock, welcome to ask.fedora!
Hotspots should work - so let’s try to debug a little bit. Have you checked the output in the system logs via journalctl? nmcli/Networkmanager should log there and thus the setup of the hotspot and all connection attempts should show up there if I am not mistaken.

Continuing the discussion from Unable to connect to Wifi Hotspot:

A bit of an update, I am now able to get my phone connected to the hotspot, it is correctly assigned an IP address without having to assign a static IP. Though connected devices still have no internet access.

I found another person with the same issue. I used nmcli connection modify Hotspot connection.zone trusted just as they did. That fixed the IP issue, though that did not fix the grayed out hotspot wording that they were having. I was only able to start the hotspot with nmcli con up id "Hotspot"

So my guess is that I am having a system policy issue like they were?

Ya journalctl does seem to work, here is the output when connecting

May 03 20:28:57 fedora-laptop NetworkManager[4105]: [1588559337.2022] audit: op=“connection-update” uuid=“2e0e5ecf-becd-4691-9b4e-abe0f0200516” name=“Hotspot” args="802-11-wireless.cloned-mac-address,802-11-wireless.seen-bssids,802-11->
May 03 20:29:16 fedora-laptop NetworkManager[4105]: [1588559356.6148] audit: op=“connection-update” uuid=“2e0e5ecf-becd-4691-9b4e-abe0f0200516” name=“Hotspot” args="802-11-wireless.seen-bssids,connection.timestamp,ipv4.addresses,ipv4.g>
May 03 20:29:43 fedora-laptop dnsmasq-dhcp[4751]: DHCPDISCOVER(wlp2s0) 66:ff:17:1d:93:41
May 03 20:29:43 fedora-laptop dnsmasq-dhcp[4751]: DHCPOFFER(wlp2s0) 66:ff:17:1d:93:41
May 03 20:29:43 fedora-laptop dnsmasq-dhcp[4751]: DHCPREQUEST(wlp2s0) 66:ff:17:1d:93:41
May 03 20:29:43 fedora-laptop dnsmasq-dhcp[4751]: DHCPACK(wlp2s0) 66:ff:17:1d:93:41 Galaxy-Note9


Not sure why, restarting my computer did not fix the issue, but restarting the nftables service individually fixed the network connection issue.

It is not the end of the world because I can still get the hotspot up via nmcli con up Hotspot, but the gui button to start the hotspot is grayed out with the message “System policy prohibits use as a Hotspot”

That’s a bit weird. But given the error message, this post might shed some more light on this, and gives even the piece of code that might be the problem here.

Regarding the restart of nftables: do you have any rules in place that might prevent ip forwarding?

Thanks @liquidat! From reading that link it sure sounds like that is what is caused my issue. I have just been using nmcli con up Hotspot for the past few days, I checked the GUI again today, and it is working! I am not sure what fixed it. Neither am I sure what in nftables might have caused the issue, as I have not made any changes and I haven’t installed any software that should have made changes to nftables.
Anyway, I am back up and running. Thanks again!

Your problem can easily have been the timing on when the interface for the hotspot is enabled and when the nftables are enabled. If the tables are created before the hotspot is enabled then the proper rules for ip forwarding (NAT) may not be created. The firewall should handle the ip forwarding but timing can be critical.

1 Like

Hi @brock, glad that you at least got it working, and can now test more to figure out what is going on. In case this was already the solution for now, please mark the post as such to make it easier for others to find this.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.