Hotspot connects but no internet connection since Fedora 32


I upgraded my fedora to version 32 from fedora 31. Although not 100% sure I am almost certain the issue occurred since this update, I can’t provide internet to my wireless devices anymore.
I can create a Hotspot using nm-applet, the hotspot is created and my devices can connect to the hotspot but can’t access the internet. I don’t have big network skills hence I opened this ticket.
Now if I use gnome and use the user settings UI the “create hotspot” button in the wifi settings is disabled and if I hover it “System policy prohibits use as a Hotspot”. It’s similar to this issue “Turn On Wifi Hotspot …” option became inactive with “System policy prohibits use as a Hotspot”. I tried to downgrade my kernel as well but the problem persist.
Again this is not related to the window manager, i tried in i3, sway, gnome on xorg, mate but nothing can do. I tried tweaking nm-applet, nmcli, nmtui but still can’t find what is the problem.
I saw the mention of the bridge elsewhere, could it be related to the bridge ? Again I really don’t know about networking well so I prefer asking.

Thanks in advance for your help

I have the same problem.

My Android phone connects to my Fedora 32 hotspot, but it hangs on “Optaining IP address…”. So it seems that upgrading to Fedora 32 breaks DHCP services. I guess this involves the dnsmasq process.

The only error message I can find is this:
dnsmasq[31753]: chown of PID file /run/ failed: Operation not permitted

I encounter a similar problem after upgrading to Fedora 32: The option for the wifi hotspot is now greyed in the network settings.

There is a work-around:

nmcli connection modify “Hotspot” trusted

(replace Hotspot with your hotspot name, see “nmcli connection show”.

See bug 1829637 – Wi-Fi hotspot stopped working after upgrade to F32


Thanks! it works well now.

In nm-applet you can change this property in “General” > " firewall zone", in the connection options.

i cannot thank you enough my good sir, you saved my battlefield 4 daily game, i was desperate. thank you

Actually, this did not solve it for me. But after some more searching I noticed that when you follow the “Connect to Hidden Network…” option in the Wi-Fi section of the gnome-control-center, then you find the Hotspot option in the list of Connections. And if you select it, it magically just works.
This may be related to this observation: