No wifi at all after 32 fresh install

Hi. I installed a new fedora 32 system, and from the first moments there were wifi issues. at first it was connecting and disconnecting, then it was extremely slow and now it can barely connect.
dmesg and the logs show a lot of
iwlwifi 0000:00:14.3: Unhandled alg: 0x707
and some
dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant/interfaces/0

lshw shows : wlp0s20f3 network Cannon Point-LP CNVi [Wireless-AC]

if you need any more outputs and info I will provide it.
if you can help that would be great, I’m stuck on that for the last two days/

Let’s grab some other information:

  1. What is the output of $ sudo lspci -vvv | fpaste ?
  2. What is the output of $ uname -r ?
  3. What type/model Access Point are you trying to connect to?
  4. Have you tried connecting to different access points? If so, did the same issue occur?
1 Like
  2. 5.6.14-300.fc32.x86_64
  3. netgear something. Doesn’t really matter since the issue is not specific to that acess point in particular.
  4. yeah ok so phone’s hotspot produces the same result. Right now I’m connecting via usb tethering which works fine.

Not an expert or anything but seems like like the iwlwifi module is the right way.

I know a guy that this happend to him also.
What he did to solve it was unloading and reloading the module to the kernel. And that just fixed it for him. He’s on debian tho with a much older kernel.
For me doing that doesn’t really change anything.

Thanks for the reply btw.