Update to F33 from F32 - Wireless adapter (Intel 8260) stopped working

Hi,
I am looking for some help. I recently updated from Fedora 32 to Fedora 33. The process was smooth and everything worked fine for a couple of reboots. Now suddenly my wireless network has stopped working. The connection GUI says that the wireless adapter for both WiFi and Bluetooth can not be found.
Here is the output of lshw -c network which shows the adapter as unclaimed:

    *-network UNCLAIMED       
       description: Network controller
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 3a
       width: 64 bits
       clock: 33MHz
       capabilities: cap_list
       configuration: latency=0
       resources: memory:f1100000-f1101fff

I have tried to manually copy the wireless driver to /lib/firmware. I have also tried to reinstall the firmware, but with no success. I have confirmed from a F33 live disk that the WiFi card is indeed working. What can I do to fix this problem?
Thanks for your help.

1 Like

You are not alone :wink:
Please have also a look at ask.fedora: