Unable to boot into fedora's GUI/home

Hello! Thanks for taking out time to go through this.

I was previously triple booting Fedora 32, Ubuntu 20.04Lts, and Windows 10 on my laptop using efi firmware, and rEFInd as my boot manager. Suddenly, windows couldn’t boot anymore, I guess after some update. At first, I thought it was from the windows boot manager, so I tried replacing it with a backup I had because I thought it must have been corrupted. I also thought that maybe the entire efi partition is bad, so I formatted it and tried generating a new windows efi boot files, not before I saved the entire content of the efi partition on the fedora partition. It didn’t work. After much troubleshooting, I decided to reinstall windows on the partition it was previously located.

I now wanted to retrieve the content of the previous efi partition so as to restore the fedora and Ubuntu efi file in the efi partition and allow them to be listed when I try booting my laptop again. In trying to access the fedora partition using a fedora live USB with no persistence overlay I created, because I could not access it from the normal boot process anymore, I tried and failed to copy and paste it. I tried mounting the folder where I saved the efi content unto the live USB Fedora system too. Finally I was able to get the previous efi content copied to the windows partition, thereafter getting it into the efi partition too.

Now the three OS are listed when I boot my Laptop, with windows and Ubuntu successfully booting into the desktop/GUI environment, but fedora could not successfully boot, rather, it takes me to emergency mode. At first I could not even get into root with this error “Cannot open access to console, the root account is locked in emergency mode”. But following an answer I found here I am now able to login to root from the emergency mode.

How can I solve this problem of me not able to login to fedora GUI normally.

1 Like

Thanks for taking out time to respond.

I currently don’t have issues with the bootloader. I am using rEFInd boot manager which can detect the “kernel”. The problem is that after I select fedora to boot the boot process doesn’t successfully complete.

Assuming that your configuration is correct, you can try to regenerate all initramfs:

sudo dracut -f --regenerate-all

Tks. But please am I to run this code from the emergency console or from a live USB?

Use live session chroot as described in the first link above.