Not able to boot into Fedora

So i am dual booting windows 11 and fedora 36, and have been for a few months, but a few days ago, the grub menu where i select which OS i want to boot into, disappeared. I’ve been trying to manually reinstall grub from a live ubuntu usb stick, and using the boot repair tool, but nothing has worked. In the report from the boot repair program (, there is only one registered OS, which is windows.
So what should i do from here?

According to the report there is no boot entry for fedora in the uefi. You can manually create one from the usb stick: sudo efibootmgr -c -d /dev/nvme0n1p5 -p 1 -L Fedora -l '\EFI\fedora\shimx64.efi'

Thanks for the response.
I’ve tried doing this, but when i choose the Fedora boot option, i just get booted into windows 11.
Also the bootloader isn’t grub, the grub boot loader menu has disappeared. When i try to boot in to fedora, i turn on my computer, and press f10, f11 and f12 (not sure which of those it is, so i just press all of them) to get to a menu where i can choose what to boot (or go into the uefi/bios). Doing what you said, there now is an option for Fedora, but it just boots me into windows 11.

You can probably change the boot order in your bios settings

Doesn’t change anything unfortunately.

It sounds like a windows update overwrote grub with the windows boot loader.
I would suggest that you boot to a live USB media then mount and chroot to the installed system and reinstall grub.

  1. boot to the live USB
  2. open a terminal window and su to root
  3. mount the root file system at /mnt
  4. mount /boot at /mnt/boot
  5. mount /boot/efi at /mnt/boot/efi
  6. for dir in proc sys dev run; do mount -o bind "/$dir" "/mnt/$dir" ; done
  7. chroot /mnt
  8. dnf reinstall grub*
  9. grub2-mkconfig -o /etc/grub2-efi.cfg

Then reboot and grub should be properly restored.
Once the reboot is complete please also do a dnf upgrade to make certain everything is completely up to date.

You should also re-install the shim packages.

By the way, instead of the chroot song and dance you can use the “–installroot” option to dnf.

dnf --installroot=/mnt reinstall ‘grub*’ ‘shim*’

And don’t forget the wildcards needs quoting here.

That works, but the user still must follow the steps and mount all the partitions as already stated before using that command.