GRUB Issue?

Good day, before I proceed into the problem proper, let me provide some context: prior to me attempting the below procedure, my laptop, dual-booting Fedora 36 and Windows 10, only boots into BIOS. Changing boot orders, restoring BIOS to defaults, and boot overrides didn’t work so I attempted the following from a Fedora 36 Live USB:

sudo su

mount /dev/mapper/live-rw /
mount /dev/sda6 /boot
mount /dev/sda1 /boot/efi

for dir in /dev /proc /sys /run; do mount --bind $dir /$dir ; done

chroot /

rm /etc/grub.d/*
rm /etc/sysconfig/grub
dnf reinstall grub2-efi shim grub2-tools
grub2-mkconfig -o /boot/grub2/grub.cfg



Taking out the USB and powering on took me to a GRUB menu. However, this GRUB menu only shows “UEFI Firmware Settings”, despite the fact that when I ran grub2-mkconfig -o /boot/grub2/grub.cfg it says that Fedora 36 is detected. Redoing the procedure yielded the same results. I could still access my files upon mounting /dev/sda6. I suspect I may have botched the chrooting procedure. Running efibootmgr after exiting chroot tells me something about EFI variables not being supported/detected. Is there anything else I can do?

Have you tried the reinstall procedure with secure boot enabled/disabled?

I attempted to reinstall, yes. In fact, that was my initial intention with the Live USB. However, the installer doesn’t seem to have an option to install over an existing OS. I couldn’t disable my Secure Boot in BIOS without following this procedure about PK variables which I don’t wish to meddle with out of fear of bricking my machine.

What you need to do for that is select a custom partitioning scheme. Then, you select each of your old partitions, assign them the same mount points that you had before, and reformat them, except for /home if you want to keep any files, configs or work you’d saved there. It’s really quite easy, although I’d suggest making a backup of /home through the LiveUSB if there’s anything you want to keep.