Twitch error 3000 on Firefox for Fedora

Unfortunately, I’m having more frustration with the Firefox for Fedora browser.

I tried to watch my brother stream on Twitch last night but I kept being met with error 3000 in the video player. I couldn’t find much good info on that error, so I took a look with terminal.

I got the error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005), which I looked up and found someone say:

Ok… it’s just the error message that is rubbish:

So I tried looking in the source code a bit and from what I could see the line just says return false but I’m not sure how that is an error.

Any ideas what the problem really is and how to fix it?

Thanks in advance! :slight_smile:

Update: Here’s the full message from terminal

Gtk-Message: 08:32:29.839: Failed to load module "pk-gtk-module"
[Child 140, MediaDecoderStateMachine #1] WARNING: Decoder=7fcd0d2f2400 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005): file /builddir/build/BUILD/firefox-88.0.1/dom/media/MediaDecoderStateMachine.cpp:3478

I believe some incompatibilities with gnome 40. Please write down the Firefox version and the Kernel you work with. If someone confirmed the problem might be the best to file a bug.

The default web browser is “GNOME Web ” (packaged as “Epiphany” browser). This might help you to work in the mean time.

1 Like

Oh, thank you for the information! I thought that Firefox was the default browser. Web (Epiphany) is playing twitch properly; that’s great!

Here’s the info you asked for:

Firefox Browser 88.0.1 (64-bit)
Mozilla Firefox for Fedora
fedora - 1.0
($) ~: uname -a
Linux fedora 5.12.6-300.fc34.x86_64 #1 SMP Sat May 22 20:42:55 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
1 Like

Well, for Twitch my experience is either using Chrome or Chromium,