Trying to install a printer driver for the Brother DCP-7055

I have been trying to install the driver for the DCP-7055 but it gives me the error:

error: Importing package ‘cupswrapperDCP7055’: Unsupported path: /usr/local/Brother/Printer/DCP7055; See https://github.com/projectatomic/rpm-ostree/issues/233

Any advice?

Is that coming from an .rpm?
What command you user to try to install it?

Yep, I use: rpm-ostree install cupswrapperDCP7055-2.0.4-2.i386.rpm

Well a few things You can try, but the first is a must. The others may in the end break your installation
or require lots of work.

  1. Send a request to Brother to correct their drivers and follow a sane standard or you will put money where your mouth is.

  2. You can try extracting the rpm into /var/usrlocal (which should be mounted to /usr/local/ and is writable)

  3. Danger, never tried this before: ostree seems to have recently gained a --hotfix option for permanent changes to your deployment. And than there is rpm-ostree usroverlay. You can play around and break your installation. (happy to know if it worked)

  4. Make your own Silverblue image with that rpm installed during compose.

Without knowing how that particular driver works I can’t tell about other workarounds like environment variables for CUPS maybe or something?

For some Brother printer’s using the equivalent open driver (Foomatic) or installing using a PPD file may give limited functionality - depending on how you intend to use the printer.

I agree with @damianatorrpm, either Brother (and other vendor’s) change their installer’s or we have to do stuff like extract the files and scripts from the RPM and install manually. This sometimes works, but is clumsy, not guaranteed and hard is to maintain/update. To make things more confusing some Brother supplied RPMs (I suspect newer models) do install OK using rpm-ostree.

I had a go at extracting an RPM (with mixed success) to address a similar issue involving an Epson scanner (Diagnosing hardware driver installation issues in Silverblue)

For me, I stopped using Silverblue and went back to regular workstation a few months back mostly because of hardware install related issues.