TP-Link wifi usb adapter problem

Hi! I’ve installed fedora 36 recently. But my wifi adapter doesn’t work properly. I can see available networks but can’t connect to them.
Adapter model: TP Link TL-WN823N-V2
I downloaded driver and followed steps in this link but when use “make” command, i got the following error:

cc1: some warnings being treated as errors
make[2]: *** [scripts/ /home/oguz/Downloads/TL-WN823N_V2_160315_Linux/Driver/core/rtw_cmd.o] Error 1
make[1]: *** [Makefile:1850: /home/oguz/Downloads/TL-WN823N_V2_160315_Linux/Driver] Error 2
make[1]: Leaving directory ‘/usr/src/kernels/5.19.10-200.fc36.x86_64’
make: *** [Makefile:1696: modules] Error 2

Can you help me with this driver installation?
So far I’ve installed Development Tools, Development Libraries and dkms. Btw I have internet connection with ethernet cable (using my laptop as bridge).

Hi, try this driver:

Next time consider device with out of the box linux support, here’s a handy list:

With your adapter plugged in please run lsusb and send us the line that is related to the adapter. It will have a part that looks like ID xxxx:xxxx and that gives us the exact chipset for that adapter.

Manufacturers do update the chipset, even within the same model of adapter, so the driver you are working with may or may not be correct. The link you post leads to this which is certainly not a guide for building the driver. It then leads to a lot of digging to even find your adapter info.

The third line of what you posted indicates that might actually be a realtech chipset and thus might need a different driver but more info is needed to confirm.

The guide I found for that adapter is for kernel 4.13 and only shows ubuntu 16.04 so it is rather out of date and certainly may not be able to be followed without modifying the commands, or possibly even the make file.

Is this the file you downloaded?

If it is, then the data on that site explicitly tells you it was written to support the OLD kernels 2.6.18 ~ 3.10.10 and it may or may not be able to even be compiled on a 5.19 kernel system.

I downloaded and tried compiling that driver and I get this.

$ sudo make
"NO SKRC,we will use default KSRC"
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.19.10-200.fc36.x86_64/build M=/home/jvian/test/tp-link/TL-WN823N(US)_V2_160315_Linux/Driver  modules
/bin/sh: -c: line 1: syntax error near unexpected token `('
/bin/sh: -c: line 1: `make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.19.10-200.fc36.x86_64/build M=/home/jvian/test/tp-link/TL-WN823N(US)_V2_160315_Linux/Driver  modules'
make: *** [Makefile:1696: modules] Error 2

and the referenced line (1696) in the makefile is
$(MAKE) ARCH=$(ARCH) CROSS_COMPILE=$(CROSS_COMPILE) -C $(KSRC) M=$(shell pwd) modules

It is obvious that I do not have the same driver package since my makefile ends at line 1732 and your error references line 1850. Also yours shows a scripts subdir and mine does not have that.

You will need to

  1. share the exact link to the file you downloaded so we can actually test your file for the error.
  2. verify that you have the correct file by giving us the output from the lsusb command as requested above.
1 Like

Thank you all, somehow I solved it. I tried couple of things and they didn’t work first but when I opened pc couple of hours later to try your solutions, I could connect to wifi successfully. I tried GitHub - Mange/rtl8192eu-linux-driver: Drivers for the rtl8192eu chipset for wireless adapters (D-Link DWA-131 rev E1 included!) and GitHub - ZeeRooo/RTL8192EU: Linux driver for Realtek RTL8192EU. . I can’t remember which one of them worked without errors but maybe it could help other who run into the same problem.

1 Like

Thank you for the update. Those 2 sources are likely more up to date than the one at tp-link. One was last updated one month ago and the other only 2 years back.


1 Like

Driver I linked is an updated version of this one (made to work with newer kernels). It’s based on newer driver from Realtek (in contrast to the other link), so in case of instability or poor performance, try it.

1 Like

I have the same problem with fedora 37. Can you help please ?

make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/6.0.7-301.fc37.x86_64/build M=/home/os/Downloads/RTL8192EU  modules
make[1]: *** /lib/modules/6.0.7-301.fc37.x86_64/build: No such file or directory.  Stop.
make: *** [Makefile:1829: modules] Error 2

What kernels are actually installed? dnf list installed kernel
What kernel is booted? uname -r