No wifi with new kernel in fedora 37

There seem to be a problem with the new kernel 6.2.7 and realtek 8852b (my wifi card): it does not work.
The wifi card works well with kernel 6.1.15
The problem is explained here:
but following the instructions I am unable to make it work
Probably my best strategy will be to remain in kernel 6.1.15 and wait for kernel 6.3.
My question is: how can I do that if there are a lot of kernel updates inbetween?
Thank you.

The link provides error messages. You should check that you are seeing the same error before trying the solution. Do you have internet access from the broken system (Ethernet or alternate wifi device)?

Tell us exactly what you did and what problem you encountered, and we may be able help you to get wifi working.

Try building the modules as explained here:
How to install the driver for wifi chip rtl8852BE? - #4 by vgaetera

If necessary, change rtw_8852be to rtw_8852b in the last config.

I don’t think that you’ve been hit by this bug, because it’s related to a firmware version, not the kernel. If so, that would explain why the suggested fix doesn’t work for you. The suggested fix consists of downloading and installing the new firmware directly, meaning that dnf doesn’t know about it. Try running sudo dnf list installed rtw8852b_fw.bin and find out what version dnf thinks you’re using.

Thank you for all your replies.
I understand that my help petition was no completely clear.
I have a ideapad 5 14ABA7 that comes with wifi card Realtek 8852BE.
I have also an external Atheros TP-LINK TL-WN722N USB WiFi card, that I can use if there are problems with the internal wifi card.
And, if necessary, I can also use an USB-C ethernet adapter.
What I did:
(1) Following

to have dkms, I had (and still have) wifi in kernels 6.1. x

(2) After sudo dnf update, I have no wifi with kernel 6.2

(3) I searched the internet, and found the bugzilla bug. I did several times
sudo cp rtw8852b_fw.bin /lib/firmware/rtw89/

and reboot every time. But still no internet in 6.2.17

I did again the instructions in

But the result is still:
inxi -N
Device-1: Realtek driver: N/A
Device-2: Qualcomm Atheros AR9271 802.11n type: USB driver: ath9k_htc

1 Like

Make sure to update the source code:

sudo git -C /usr/src/rtw89-git pull

Then boot the latest kernel and try rebuilding the modules:

sudo dkms remove rtw89/git --force --all
sudo dkms add rtw89/git
sudo dkms install rtw89/git

If the issue persists, you can try to file a bug to this repo:
Issues · lwfinger/rtw89 · GitHub

Thank you Vladislav.
It did not work
sudo dkms add rtw89/git
Error! DKMS tree already contains: rtw89-git
I took a look to man dkms, but it’s too much information to digest.
By now I’ll wait a new kernel. I have wifi in 6.1.x and with tp-link in every kernel.
Thank you for your help again.

You can manually clean old DKMS entries, see:

dkms status; find /var/lib/dkms -maxdepth 2

Man pages are often very terse, lack examples, and assume some background knowledge. They are usually better suited to refreshing your memory and discovering details of a particular implementation.

The dkms software is from Dell, so is not specific to Fedora. This means you can look to other distros for dkms documentation. Arch Linux is known for excellent documentation (you do have to substitute Fedora dnf operations in place of Arch’s pacman operations). See [Arch Dynamic Kernel Module Support].(Dynamic Kernel Module Support - ArchWiki)

Why? If it didn’t work the first time, why did you think that doing the exact same thing again would work? I’m not trying to put you down, it’s just that I don’t understand why you were expecting a different result.

Thank you for all your replies. I found this web page with exactly the same problem as mine, and the same result in dmesg | grep 8852

although I do not understand, I did

git checkout bea0ed7

and, after compiling, at last I have the driver working:
inxi -N
Device-1: Realtek driver: rtw89_8852be
Device-2: Qualcomm Atheros AR9271 802.11n type: USB driver: ath9k_htc
Thank you again.