Throttling due to ACPI?

My CPU and GPU temps are normal now and with thermald properly configured I’m not getting any random spikes of CPU temps

When I’m playing something everything runs well but every 5-7 minutes it starts stuttering like hell. I checked using sensors and CPU temps were fine(around 75 C) but at the end I see this - acpitz-acpi-0 Adapter: ACPI interface with 96 C temp. The stutter lasts for around 30 seconds and then goes back to normal at which point the temp showed in ACPI goes down to 76 C.

I don’t think this is a hardware issue since this doesn’t happen at all on windows 10 on the same system and with the same games(native and ones with good rating on protondb).

Looking this up online I don’t find much other than the fact that ACPI is related to power?

Does anyone know what’s going on here?

check thermald --help and have a look if this might help with the power:

–disable-active-power Disable active power settings to reduce thermal impact

1 Like

it worked for a while but I’m getting the throttling again now

something I want to add to this - I ran –disable-active-power again to check if it’s something that needs to be run everytime but it was still throttling in the same manner I described.

I noticed something else though. Around the time when it started throttling again, the problem reporter noted two problems.

  1. Pipewire quit unexpectedly

  2. Unexpected system error