PC stutters in games after being idle or after waking up from sleep on AMD GPU

Hi everyone,
I am experiencing a problem with my PC, after being idle for some time or after waking it up from sleep it starts to stutter in games until I reboot the system.

For example when playing ELDEN RING shortly after turning on the PC it runs smoothly, no performance or audio issues whatsoever, but upon reopening the same game after leaving the PC idle and roaming around in the same areas as when it was running smoothly, it stutters and the audio becomes slightly corrupted.

My system:

Operating System: Fedora Linux 40
KDE Plasma Version: 6.1.0
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.1
Kernel Version: 6.9.5-200.fc40.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 7800X3D 8-Core Processor
Memory: 31.0 GiB of RAM
Graphics Processor: AMD Radeon RX 7900 XTX
Manufacturer: ASRock
Product Name: X670E Taichi

Thank you

Can you try a older kernel ? You should have 3 to choose from…

Also, If you can reproduce consistently, run these commands and pste here in </> preformatted text :

  • inxi -Fzxx

and

  • journalctl -xe | fpaste --raw-url and Paste the url here for us to look at the logs.

Here’s the info of inxi -Fzxx:

System:
  Kernel: 6.9.5-200.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: KDE Plasma v: 6.1.0 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
    Distro: Fedora Linux 40 (KDE Plasma)
Machine:
  Type: Desktop Mobo: ASRock model: X670E Taichi serial: <superuser required>
    UEFI: American Megatrends LLC. v: 2.08 date: 03/01/2024
CPU:
  Info: 8-core model: AMD Ryzen 7 7800X3D bits: 64 type: MT MCP arch: Zen 4
    rev: 2 cache: L1: 512 KiB L2: 8 MiB L3: 96 MiB
  Speed (MHz): avg: 2114 high: 4985 min/max: 400/5050 cores: 1: 4329 2: 400
    3: 400 4: 3378 5: 400 6: 4656 7: 4027 8: 400 9: 4009 10: 4985 11: 400
    12: 400 13: 400 14: 4842 15: 400 16: 400 bogomips: 134419
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX/7900M]
    vendor: Sapphire NITRO+ driver: amdgpu v: kernel arch: RDNA-3 pcie:
    speed: 16 GT/s lanes: 16 ports: active: DP-1 empty: DP-2, HDMI-A-1,
    HDMI-A-2, Writeback-1 bus-ID: 03:00.0 chip-ID: 1002:744c
  Display: wayland server: Xwayland v: 24.1.0 compositor: kwin_wayland
    driver: N/A display-ID: 0
  Monitor-1: DP-1 res: 2560x1440 size: N/A
  API: EGL v: 1.5 platforms: device: 0 drv: radeonsi device: 1 drv: swrast
    surfaceless: drv: radeonsi wayland: drv: radeonsi x11: drv: radeonsi
    inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.2 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon RX 7900 XTX (radeonsi navi31 LLVM
    18.1.6 DRM 3.57 6.9.5-200.fc40.x86_64) device-ID: 1002:744c
    display-ID: :0.0
  API: Vulkan v: 1.3.283 surfaces: xcb,xlib,wayland device: 0
    type: discrete-gpu driver: N/A device-ID: 1002:744c device: 1 type: cpu
    driver: N/A device-ID: 10005:0000
Audio:
  Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30
  Device-2: AMD Family 17h/19h HD Audio driver: N/A pcie: speed: 16 GT/s
    lanes: 16 bus-ID: 59:00.6 chip-ID: 1022:15e3
  Device-3: Generic USB Audio driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 5-8:6 chip-ID: 26ce:0a06
  Device-4: Fifine Microphone driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 bus-ID: 9-2:3 chip-ID: 3142:5060
  API: ALSA v: k6.9.5-200.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Intel Wi-Fi 6E AX210/AX1675 2x2 [Typhoon Peak]
    vendor: Rivet Networks Killer driver: iwlwifi v: kernel pcie: speed: 5 GT/s
    lanes: 1 bus-ID: 49:00.0 chip-ID: 8086:2725
  IF: wlp73s0 state: down mac: <filter>
  Device-2: Realtek Killer E3000 2.5GbE vendor: ASRock driver: r8169
    v: kernel pcie: speed: 5 GT/s lanes: 1 port: b000 bus-ID: 4a:00.0
    chip-ID: 10ec:3000
  IF: enp74s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 5-7:5 chip-ID: 8087:0032
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.3 lmp-v: 12
Drives:
  Local Storage: total: 2.27 TiB used: 399.79 GiB (17.2%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 2TB size: 1.82 TiB
    speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 48.9 C
  ID-2: /dev/nvme1n1 vendor: Crucial model: CT500P5PSSD8 size: 465.76 GiB
    speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 50.9 C
Partition:
  ID-1: / size: 464.17 GiB used: 18.04 GiB (3.9%) fs: btrfs
    dev: /dev/nvme1n1p3
  ID-2: /boot size: 973.4 MiB used: 323.3 MiB (33.2%) fs: ext4
    dev: /dev/nvme1n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
    dev: /dev/nvme1n1p1
  ID-4: /home size: 464.17 GiB used: 18.04 GiB (3.9%) fs: btrfs
    dev: /dev/nvme1n1p3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 58.2 C mobo: N/A gpu: amdgpu temp: 55.0 C
    mem: 69.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 134
Info:
  Memory: total: 32 GiB note: est. available: 30.95 GiB used: 13 GiB (42.0%)
  Processes: 678 Power: uptime: 1h 54m wakeups: 1 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 15 Compilers: N/A Shell: Bash v: 5.2.26
    running-in: konsole inxi: 3.3.34

Here’s the link of journalctl -xe | fpaste --raw-url:

[Info](https://paste.centos.org/view/raw/e602ccea)

Thank you

There were some errors related to media decoding in Firefox and compatibility issues with 32-bit libraries in the game.

[Child 12345, MediaPlayback #1] WARNING: Decoder=0xdeadbeef Decode error: 
NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - 
RefPtr<mozilla::MozPromise<RefPtr<mozilla::MediaTrackDemuxer::SamplesHolder>, 
mozilla::MediaResult, true> > mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): 
manager is detached.: file /path/to/firefox/dom/media/MediaDecoderStateMachine.cpp, line 
1234

Could you try to not launch firefox while playing the game?

Also :

[Steam] Launch error: Failed to load library 'legacy_dll.so': 
(lib32compat.so: cannot open shared object file: No such file or directory)

Do you have all the necessary 32bit libraries installed?

Is there a way to fix this problem with Firefox?

I have installed Fedora quite recently and it’s most likely that i did not install them.

I launched the Game before opening Firefox and after Opening it, in both cases it was running well

Thank you

You could try Hardware enablement in the Firefox Browser settings.

I noticed while running inxi -Fzxx:

Monitor-1: DP-1 res: 2560x1440 size: N/A

In my case it’s not a 2K Monitor but a 4K Monitor with a refresh rate of 240hz with the screen size of 32". I don’t know if it might be problematic.

I enabled it.

ELDEN RING and other games still stutter even with Firefox closed.

I believe something breaks after sometime thus leading to stutters and audio issues

What version of Proton are you using? With your setup, you should be on Proton Experimental.

Also, have you tried Proton-GE ? Sometimes it solves these issues due to winetricks and other features Steam Proton cannot ship.

I just tried playing ELDEN RING with the latest Proton GE and I could hear the audio issues even in the Menu.
After loading the save file the audio became a lot worse and the stuttering was easy to notice.

And if that wasn’t enough even an YouTube video started freezing when launching the game although the audio was doing fine in that case.

Is there an option in the motherboard BIOS I should check?

No, this doesn’t have anything to do with your BIOS.

From a previous post, do you have the 32bit libraries installed ?

I don’t know, if they aren’t present what should I install?

Tinker Steps:Custom Proton: GE
Audio:Other

Crash at launch with audient interface, 
adding an audio sink solve the issue

There could be other solutions here for you. Also, try a Stable version of Steam Proton. You should have a couple to choose from the menu.

The weird thing is that it only happens randomly after some time.
I’ve seen it happening like an hour later after some smooth game time without any issues.
The stuttering also affects other games like HELLDIVERS 2, but only after the problem started.
A reboot fixes the issue.

Try and reach out on the ProtonDB site, Steam Forums or WINE forums for help. As this is not Fedora specific, there’s not much more we can do here.

Proton-GE has a Discord, So you might can join that.

Ok, I’ll do.

Thank you for your help