Fedora 31 kernel issue/crash at boot (acpi?/disabling icq 9)

First off, pretty new to Linux here, just a heads up!

I installed fedora 31 with kde on my Lenovo 330-15ICH a couple of days ago, every time I boot I get the same error.

when doing cat /procc/interrupts I found this: 9: 0 100000 0 0 0 0 0 0 IR-IO-APIC 9-fasteoi acpi

What I have tried so far is updating to latest bios, disabled onboard wifi and nvidia card, irqpoll(system goes extremely slow and cannot login). I’ve also tried disabling nouvou, and completely removing the driver. I first thought it was wifi, or gpu that caused the issue, but I guess it’s the ACPI power saving something?

Anyone have any suggestions on what I might try?


Did your read the first line?
“The backtrace … It is annoying but it does not necessary signalize a problem with your computer … but you can contact kernel maintainers via e-mail”.

Also the second line:
irq 9: nobody cared (try …

You extend a bit more here is another case with the same issue. It is a bit old but maybe show to you a bit better the issue.


You can try irqfixup parameter in place of irqpoll which did your system slow to see if this does difference and so avoid the abrt mesg. And waiting for a update of your firmware if it is not a hardware issue.

    irqfixup        [HW]
                    When an interrupt is not handled search all handlers
                    for it. Intended to get systems with badly broken
                    firmware running.

    irqpoll         [HW]
                    When an interrupt is not handled search all handlers
                    for it. Also check all handlers each timer
                    interrupt. Intended to get systems with badly broken
                    firmware running.


1 Like

I got something similar yesterday. Three new boots and 2 reboots since then and it didn’t occur again.
ABRT is the main suspect for both cases.

Hi! Thank you for your replies. I’ve also tried irqfixup with no luck, it also makes the system slow and I am unable to login. So I guess this comes down to this question, what is actually crashing? Is it the ACPI, and if so, as far as I’ve understood it, this has to do with the laptop power saving modes? In which case, acpi crashing is kind of a deal breaker as that would greatly affect the battery life?

1 Like

Here is my entire dmesg: dmesdg - Pastebin.com

@tuh first check in your BIOS for a TPM option and enable TPM if it is disable like it looks like indicate your dmesg.

[    1.801192] ima: Error Communicating to TPM chip

respect the problems with related with acpi and irq, you can try boot with thes options acpi=off and noapic , test in mode tempory(see here)

Maybe they can do the trick as a workaround until an new update of the kernel.