Terminal not showing full text

Hi everyone. Many thanks in advance.

I am a beginner to terminal.
When I tried listing all the flatpak apps, I cannot get the full Application ID, some of the text is short. This also happens in full screen. How can I display the full text?


You need an adequate terminal width to allow the text to display. Stretch the terminal window width wider.

The branch names indicate you may not be running fedora so this might not be the best location to get good advice.

We do need to know the OS (fedora or other) and version (35, 36, Workstation, silverblue, etc.) you are running, as well as the desktop you are using (gnome, kde, etc.). We also need to know if you are running a terminal window or actual virtual terminal.

1 Like

Pay attention. These branch versions are related to flatpak runtimes (I suppose).

Thanks for replying. I am on Fedora 36 GNOME with the Latest Kernel 5.19. It is running on my laptop with 1920×1080 screen. The text doesnt expand even after trying to adjust the width by dragging the terminal.

Try with this command: flatpak list --columns=name,application:f

flatpak list --help suggest this:

Append :s[tart], :m[iddle], :e[nd] or :f[ull] to change ellipsization

Thanks. Is there a way I can turn off ellipsization in terminal settings? Because this issue extends beyond flatpak list command.

You can redirect the output like this

flatpak | less


flatpak > /tmp/flatpaklist ; nano /tmp/flatpaklist

or even an appearently useless usage of the cat command

flatpak | cat

The trick is that when the output is not a terminal it does not have the with of the terminal to truncate the text.

1 Like

1920×1080 is not a small resolution.
Where do you encounter other issues?

1 Like

The only difference I see when running flatpak list vs flatpak list | tee (or one of the others) is that there’s less whitespace between the columns and the column headers aren’t shown, but the actual output otherwise is mostly the same. I do start to see some truncation in the former (see Qt ones), but I’m at way less than 1080p width before I see that.

(Screenshot to best preserve output format):


The resolution 1920x1080 is not important here. Important is the with of the terminal window and the font size, and thereby how many letters fits across the terminal window. Adjusting that so you can fit 100 characters across the screen instead if only 80 would make a big difference.

1 Like

I don’t see any output format options for that in the flatpak command itself, but piping to tee or one of the other options looks like it will get you what you want.

If you really want to preserve the format, here you go:

column -t <<< $(flatpak list | tee )

1 Like

For me, with the gnome-console, text size can be adjusted as well as the terminal window width. Select the ‘hamburger’ menu icon then adjust the scaling to change text size. Drag the edges of the window to change window width.


Now that I checked the other commands I used in Terminal, none of them had ellipsization or … (dots).

Using the flatpak list --apps command also listed everything in full length. But then I tried it again after a while and there was ellipsization. It seems it is randomly happening. I haven’t changed the window size or the font size. I am using the GNOME Terminal with original window size.

Also note that even when I switch to full screen, the ellipsization doesn’t go away.

Do you ever see this with this method at the bottom of this post?


No. It displays full text then. But why is it having ellipsization with simple flatpak list command? Is it just a random bug or something else explains it?

flatpak list --help
To me, since there are options to control it, this ellipsization looks like a characteristic of this specific command.


Yes, and flatpak list options --help shows more detail for the current issue.


Try this

flatpak --columns=name,application remote-ls

It will display only two columns. Run man flatpak-list to get other possible options.


Got it.

Many thanks to everyone who replied and elaborated.

1 Like