System Freezes with kernel 5.14.16-101.fc33

Since the update on Fedora 33 which installed kernel 5.14.16-101.fc33 my system has just stopped responding 4 times in less than a week. The problem is the same as I have experienced for about the last 5 years, however the problem seemed to have gone away sometime earlier this year in that I have experienced a system freeze in at least 6 months but now it’s back. I updated my hardware in the spring from 11 year old hardware believing that was the problem and convinced myself that the old hardware was broken but I couldn’t ever figure out what was wrong, On the new hardware I have run at least 6 month and probably 8 months without a system freeze until I updated to the kernel.

When I say system freeze I mean I can be working on the system with every thing working and then the mouse cursor will still move but nothing else will happen. For example I was in files and clicked to create a new folder and the system gave me a box to name it but I couldn’t get focus in the name box or anywhere else. I waited approximately 30 minutes still the same thing. The only was to get a response from the system is to power down and back up. On the other 3 occasions I have found the system in the morning in a state were the screen has blanked out and I get it to wake for input of password.

I leave the system running 24/7 so cron can take care of some things for me during the night. So frustrating!!

System error logging show nothing. I do get an OOPS notification upon reboot but it says not enough information to report a bug and suggest that I contact kernel developers by email. Not helpful since I don’t have any kernel developer email addresses. I have attempted to report this same type of failure in years past and everyone seems to think it hardware possible memory. I have run memtest for a few days with no errors (this was on my old hardware). Every thing is purely random.

Any help on who or how to report this type problem would be appreciated as well as is anyone else experiencing this type problem. I run fedora as my exclusive system no other OS and that has worked for a long time but I thinking I may have miscalculated and still need a system that mirrors this installation with windows OS.

Thanks for any help offered.

Booting with kernel 5.14.15-100.fc33.x86_64 I’ve been running for 5 days without an incident. I’m afraid to update to the latest update which contains a new kernel (5.14.17-101.fc33) fearing that I will lose the 5.14.15 kernel which works.

There were some io-scheduler issues with the 5.14.x kernels, but they’re meant to be fixed now:

The workaround is to move off the bfq scheduler, as noted here. Give that a try and see if anything changes?

PS: dnf should not remove the currently running kernel, so if you update while running 5.14.15, that’ll remain. (Of course, check the transaction information to be sure of this).

1 Like

Do you know which kernel this was fixed in?

It says:

“kernel-5.14.9-200.fc34 kernel-5.14.9-300.fc35 kernel-5.14.9-100.fc33”

(You can find that information in the “Fixed in version” field of the bug. )

1 Like

How do you set the default scheduler ? When I google, I find the recomendation to add elevator=mq-deadline to the comand line but this no longer works.

[    0.100978] Kernel command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.15.4-200.fc35.x86_64 root=UUID=79fef31e-b105-4d11-a856-d983b42c57bf ro rootflags=subvol=root rhgb quiet elevator=none
[    0.101073] Kernel parameter elevator= does not have any effect anymore.
1 Like