Fedora 35 KDE Plasma kernel 5.15.16 freezing system

I’m just poking around to see if anyone has had issues with kernel 5.15.16 with a NVIDIA card.
I just attempted a dnf update, rebooted and the system freezes at the login screen. I attempted a few reboots and only once was I able to login but it immediately froze. I rebooted back into 5.15.14 and am working normal now.
I have an NVIDIA GeForce GTX 970. Looking at the dnf log it looks as if it updated to the 495.46 driver.
Anyone else having issues with 5.15.16 with NVIDIA?

I have the latest kernel 5.15.16 and the latest nvidia driver 495.46 and haven’t had any issues.

So, is it possible that I messed something up with the update process by using dnf update instead of the KDE Update tool?
I don’t normally like using the KDE Update tool because most times when I use it it states to reboot after every update and then when I boot back into the operating system the KDE Update tool states I have more updates to install, installs them and reboots again. There have been times this process has taken 3 attempts, and 3 reboots, before the system is updated.
I’m relatively new to the new version of KDE (first used it for a short time about 15 years ago before switching to other DEs) and I’m not too familiar with the update process using the KDE Update tool. I’ve been using Gnome for several years and I have always just gone the dnf update path without issues, until now.
I’m still typing this now without the system freezing under kernel 5.15.14 using NVIDIA driver 495.46. I have yet to be able to use kernel 5.15.16 without it freezing at login screen. There have been a couple of times I have been able to login but the system freezes within 5 minutes of use.

I assume you are using wayland with kde since that is the new default for fedora.

Have you tried to login using xorg? Nvidia + Wayland still are not at the 100% functional level and it may be that you are a victim of that issue. At least try the xorg route and see if there is a difference. If the problem is solved with xorg then this is a bug I would report against wayland so the developers have some info to work on for improvement.

I forgot to mention that in my original post, that I am booting into X11. However, I don’t think it is a X11 versus Wayland issue since, most of the time, it freezes before I login at the login screen.

OK, then that may be a driver issue.

Did you install the driver from rpmfusion? If so then there is an easy way to check if it is the driver.
sudo dnf swap akmod-nvidia-495* akmod-nvidia-470xx --allowereasing

This will replace the 495.46 driver with the latest 470.94 driver and the reboot will allow you to see if it was the driver or something else that caused the problem. It also will prevent another update from automatically replacing the 470 driver again.

Yep, through rpmfusion. Let me try that. Thanks.

Nope. Didn’t work. I ran the command, rebooted into 5.15.16 and it froze when I logged in. Rebooted back into 5.15.14 and it is running fine.
One thing I noticed when it froze I was able to ssh into my machine and when I ran modinfo -F version nvidia it couldn’t find the NVIDIA driver information. Running that same command now in kernel 5.15.14 displays 495.46.

Ok, you need to boot to the kernel you want the driver installed for, then wait a few moments. The “freeze” could be nothing more than the time required for the system to build the kernel modules for that version of the package.

To revert back to the 495 driver simply reverse the position of the package names in the previous command.

If you can log in via ssh, then when it has booted and is “frozen” then you should copy and post the output of dmesg | tail -500 and journalctl -b 0 | tail -500 (in the </> Preformatted text tags from above) so we can see what the system says is the issue.

For this testing please use only xorg for login so we can at least eliminate one variable.

Sure. I will do that. Thanks. Have to leave for a mini-vacation now for the next couple of days for my birthday. Sucks this happened just before planned events. I will have to continue troubleshooting when I get back.
But, I will also leave you with this screenshot:

Not sure how reliable that Problem Reporting is for this issue.

Okay. Back from my mini-vacation and troubleshooting. Logged into kernel 5.15.16. Once I got to the login screen the system froze. However, from a different machine I was able to ssh and retrieve this output from dmesg:

101.879052] nouveau 0000:02:00.0: fifo: SCHED_ERROR 0c

And this message from journalctl:

Jan 30 03:15:23 edfed.offworld.lan kernel: nouveau 0000:02:00.0: fifo: SCHED_ERROR 0c

Would that be pointing to a driver conflict? My assumption is that it is but I’m going to comb the interwebs anyway to see if this is a common message.

More updates…
Looks as if 5.15.17 is out and I have updated (via KDE updater this time). I’ve booted into 5.15.17 and so far no system freezes. I have to leave for work soon so I will know it’s stable if the system hasn’t frozen by the time i get back from work. I’ve looked at dmesg and Journalctl and I am no longer seeing the same messages as before in regards to nouveau.

Just got home and the system is not frozen. So, update to kernel 5.15.17 seemed to fix the issue.
Is it possible 5.15.16 was buggy with NVIDIA? Or, could I still have an issue if the Nouveau driver is still installed?

Nouveau driver installed but not active should not affect anything. It is certainly possible that the kernel update + whatever else may have been updated had an affect.

BTW, it is a really bad idea to consider removing the nouveau driver because if for some reason the nvidia driver were to not work then you could not use the nvidia GPU in any way. There are only 2 known drivers for the nvidia GPUs. Nouveau which is FOSS and distributed and installed by fedora, and the proprietary nvidia driver which gets significantly better performance out of the nvidia card.

Understood. I will leave “as is” and hope for no more issues. As of now, so far so good.
Thanks, @computersavvy for all your replies and assistance.