Just updated from 32 to 35, can't get past login screen

Hello everyone! Recently I upgraded my Linux kernel and Fedora version from 32 to 35. This used to happen automatically but for some reason it doesn’t anymore. Anyway I got everything upgraded and at first it wouldn’t boot up at all. It still booted fine into command line mode and also into the old kernel (though that was unstable) so I sifted through some error logs and found the nVidia drivers weren’t working–I’m using a Geforce GTX 1060. So I updated the nVidia driver to the most recent version that just got released last month.

Now, it gets a little farther. It boots up fine, and then the KDE login screen comes up. I type in my password, and…the screen goes blank for a few seconds, then the login screen reappears without the password I just typed. I can’t log in. Does anyone know what’s happening here?

Where did you install the nvidia driver from? Was it nvidia? or rpmfusion?

What version of the driver did you install?

Are you using wayland or X?

Some systems have a real problem using wayland with nvidia, even with the latest (from rpmfusion) nvidia driver version 495.46. Most have no problem using X instead of wayland. The choice to use X or wayland is available with the gear in the lower right corner of the password login screen.

One advantage of using the nvidia drivers from rpmfusion is that they get updated with each driver update or kernel update so you do not have to manually recompile the driver with each kernel change as is the case if installed directly from nvidia.

I got the driver from nVidia. It’s the latest version, 495.46. As for Wayland/X, I seem to be using Wayland. This is something I’ve never paid attention to before, but “Wayland” is at the bottom of the login screen since I upgraded. Maybe I’ll try X next and see what happens…

Also I’ve been looking through the error logs just now and can’t see anything out of the ordinary.

I would suggest you remove the driver from nvidia, and add the repos for rpmfusion then reinstall the driver using sudo dnf install akmod-nvidia-495*. Once that is done you will no longer need to worry about manually recompiling the driver module with every kernel update (which may happen as often as weekly).

The proper repo for that driver is enabled by opening the gnome software app and at the top will be a link to “enable 3rd party repos”. That will enable the rpmfusion-nonfree-nvidia-driver repo for fedora 35.

Wow, just using X11 instead of Wayland worked. That was easy! Thanks!

Of course maybe there will be a problem later, I’ll be back if so…

And next up I’ll probably switch to the rpmfusion driver.

One other thing…this machine used to upgrade it’s kernel and Fedora version every time there was a new one. After Fedora 32 it just stopped which is why I just now leaped from 32 to 35. Is there a reason for this?

Fedora 35, with a new install, does do auto updates. I think that is a combined function of package kit and gnome software. I did not like it (and disabled it) since I run a cron job to do the updates on my own schedule and the new process does what is known as ‘offline updates’.

It impacts both shutdown and startup times as it does it when you power off and back on, delaying the shutdown while downloading/updating.

My machine is on 24/7 and the auto update reminded me too much of the MS forced updates. I want the updates, but on my schedule, not on a schedule I do not control.

Fedora version updates however, in my experience, have never been an automatic process. You have to manually select when you want to do the version update and I usually do it with the dnf system-upgrade plugin.