Stuck on installing boot loader

Hi everyone! I’ve been using Fedora on my laptop since version 35.
My laptop has two drives, I had Windows 11 installed on a SSD and Fedora 38 on a HDD. Recently, I decided to ditch Windows completely and install Fedora on the SSD. However, I’ve ran into some problems with the installation.

Most of the times I tried to install Fedora on my SSD, the installation progress got stuck on “Installing boot loader”.

Sometimes, a dialog with the message “An unknown error has occurred” showed up and forced me to reboot and start over.

I have tried to create the installation media again using both Fedora Media Writer and Rufus but the problem persists.
However, when I tried to install Fedora on the HDD using the same installation media, it was a complete success on the first try.

I’ve done some research but I haven’t found anything, so any help would be appreciated. Thank you!

I suggest disconnect the HDD then install on the SSD. Should work.

You also should select the SSD as the target drive and tell the installer to wipe out the existing file systems and use the entire drive.

I have tried disconnecting the HDD and it didn’t work either. Sometimes the installation process ends in a few hours but an error shows up when booting into the system.

As for the storage configuration, I always select “Automatic” and check “Free up space by removing or shrinking existing partitions”. Then I delete everything in the drive.

This sounds more like a hardware or connection issue and not an actual installation issue.
Installation should usually take no more than an hour (usually much less) so if it is taking a few hours then something else seems wrong.

Can you provide the output of inxi -Fzxx when booted into the install media with only the SSD attached. Inxi can be installed into the live media OS.

Is the SSD sata connected? or is it NVME?

What about the bios on the laptop? Is it fully updated?
What make and model is the laptop?

as said I would also suggest to disconnect the HD and then I would do

  • get a install iso with all updates (up to 2023-08-16) included from here:
    Index of /pub/alt/live-respins

  • when the install cd/usb comes up: choose test the install media

  • when the install cd/usb has booted (ready to install): key in in the top search field: “disk”

  • completely format the ssd and end the disk program afterwards

  • try to install F38

maybe with custom partitioning:

via Advanced Custom (Blivet-GUI) with an empty disk

- add a 1 GB ext4 Partition
	* Device Typ: Partition
	* Size: 1 GB
	* Filesystem: ext4 
	* label: BOOT
	* mountpoint: /boot
- add a 1 GB efi Partition
	* Device Typ: Partition
	* Size: 1 GB
	* Filesystem: EFI System Partition
	* label: EFI
	* mountpoint: /boot/efi

- add for the rest of the remaining disk minus ~10 % (!!!) a btrfs Volume
	* Device Typ: Btrfs Volume
	* Size: whole remaining disk minus 10 % (10% for Over-Provisioning !)
	* Name: BTRFS_Pool
click on the most left side: BTRFS_POOL and create (at least 2 Subvolume for / and /home)
- for /
	* Name: ROOT
	* mountpoint: /

- for /home
	* Name: HOME
	* mountpoint: /home
what I ususally do (a 3. Subvolume):
- for big data (Video/Music/ISO) a subvolume called DATA
	* Name: DATA
	* mountpoint: /home/DATA
	* after installation linked/bookmarked via nautilus to my user home

My laptop is a Dell Studio 1737. I have it since 2009, if I remember correctly. It is quite old but it holds up decently and I don’t want to dispose of it.
I have the latest BIOS update available installed, which is from 2011. Also, the SSD has a SATA conection.

Here is the output from inxi:

  Kernel: 6.2.9-300.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-9.fc38 Desktop: GNOME v: 44.0 tk: GTK v: 3.24.37 wm: gnome-shell
    dm: GDM Distro: Fedora release 38 (Thirty Eight)
  Type: Portable System: Dell product: Studio 1737 v: A09
    serial: <superuser required>
  Mobo: Dell model: 0P786H v: A09 serial: <superuser required> BIOS: Dell
    v: A09 date: 04/14/2011
  ID-1: BAT0 charge: 65.3 Wh (100.0%) condition: 65.3/5.2 Wh (1256.7%)
    volts: 12.6 min: 11.1 model: SIMPLO Dell serial: <filter> status: full
  Info: dual core model: Intel Core2 Duo P8400 bits: 64 type: MCP arch: Penryn
    rev: 6 cache: L1: 128 KiB L2: 3 MiB
  Speed (MHz): avg: 871 high: 945 min/max: 800/2267 cores: 1: 798 2: 945
    bogomips: 9044
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx
  Device-1: AMD RV635/M86 [Mobility Radeon HD 3650] vendor: Dell
    driver: radeon v: kernel arch: TeraScale pcie: speed: 2.5 GT/s lanes: 16
    ports: active: LVDS-1 empty: HDMI-A-1,VGA-1 bus-ID: 01:00.0
    chip-ID: 1002:9591
  Device-2: Microdia Laptop_Integrated_Webcam_2M driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-6:3 chip-ID: 0c45:63fa
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: X: loaded: radeon
    unloaded: fbdev,modesetting,vesa dri: r600 gpu: radeon display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96
  Monitor-1: LVDS-1 mapped: LVDS model: Seiko Epson 0x5443 res: 1920x1200
    dpi: 133 diag: 433mm (17.1")
  API: OpenGL v: 3.3 Mesa 23.0.1 renderer: AMD RV635 (DRM 2.50.0 /
    6.2.9-300.fc38.x86_64 LLVM 16.0.0) compat-v: 3.0 direct-render: Yes
  Device-1: Intel 82801I HD Audio vendor: Dell driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:293e
  Device-2: AMD RV635 HDMI Audio [Radeon HD 3650/3730/3750] vendor: Dell
    driver: snd_hda_intel v: kernel pcie: speed: 2.5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 1002:aa20
  API: ALSA v: k6.2.9-300.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.67 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Intel Ultimate N WiFi Link 5300 driver: iwlwifi v: kernel pcie:
    speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:4235
  IF: wlp4s0 state: up mac: <filter>
  Device-2: Broadcom NetLink BCM5784M Gigabit Ethernet PCIe vendor: Dell
    driver: tg3 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: N/A
    bus-ID: 08:00.0 chip-ID: 14e4:1698
  IF: enp8s0 state: down mac: <filter>
  Local Storage: total: 231.07 GiB used: 7.94 GiB (3.4%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB
    speed: 1.5 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: Generic model: Flash Disk size: 7.5 GiB type: USB
    rev: 2.0 spd: 480 Mb/s lanes: 1 serial: <filter>
  ID-1: / size: 7.36 GiB used: 5.99 GiB (81.5%) fs: ext4 dev: /dev/dm-0
    mapped: live-rw
  ID-1: swap-1 type: zram size: 3.78 GiB used: 4.5 MiB (0.1%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 61.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 2536 fan-2: 2542 fan-3: 2542
  Processes: 218 Uptime: 9m Memory: total: 4 GiB available: 3.78 GiB
  used: 1.36 GiB (36.1%) Init: systemd v: 253 target: graphical (5)
  default: graphical Compilers: N/A Packages: pm: rpm pkgs: N/A
  note: see --rpm Shell: Bash v: 5.2.15 running-in: gnome-terminal
  inxi: 3.3.29

With the age of that system I have to ask if the bios supports uefi boot? Some do and some don’t. I need to ask how you did the ssd partitioning. Was the partition table written as dos or gpt? It probably does not matter, and the pic you show where it appears to hang seems to indicate everything went well to that point.

My instincts say that if you already created a partition on that drive then it would be best to use sudo gdisk from the live media and write a blank gpt partition table and nothing else to that drive. This is based on the fact that the installer will create the needed partitions during install. Once the blank partition table is written then repeat the install.

With the older and slow CPU and small amount of RAM you have, the install, especially during the bootloader stage, will take some time.

Try again, and if it gets to the point you show in the first image just be patient and allow it to continue even if it seems to hang. It probably is just taking a loooonnnng time to complete all the configs. Even my much newer and faster system still takes several minutes at that stage of the install.

Ideally you should use the Report bug button. You’ll need a RH Bugzilla account and an API key created in its UI. Or you can at least expand that More info toggle and post the info here (possibly to some pastebin and link it).

The BIOS doesn’t support UEFI and the partition table was written as GPT.

I have downloaded the updated ISO that @sixpack13 recommended. From the live media, I have formatted the SSD with GNOME Disks and I have tried to repeat the install. After a few hours the system was apparently installed.
When I booted into the system, an error showed up.

The Spanish translation would be “Something went wrong. A problem occured and the system can’t be recovered. Contact with a system administrator”.
To my surprise, after a few minutes the error screen went away and the Fedora welcome screen appeared. I was able to set up my user and enter the desktop. Everything seems to work but it is really slow, much slower than in the HDD. Now, booting into the system takes 10 minutes, while it took from 2 to 4 minutes with the HDD. Something is definitely wrong.

I’ll do that the next time the error appears, thanks.

This might be the issue. An older system that does not support UEFI may also have problems with a GPT partitioned disk. I would not expect that, but it seems possible.

Both gnome and kde are demanding as to resources required. Maybe try one of the less demanding DE spins such as LXDE, LXQT, i3, etc. which have a much lighter (in terms of resources required) footprint for the desktop and are easier to use with a system that is limited both in cpu and ram. The alternate iso is available from the same link as given above.


It makes sense, although I don’t understand why Fedora works fine in the HDD with the same hardware. Shouldn’t it be at least usable with the SSD? :thinking:

By the way, I also tried installing Linux Mint out of curiosity and I ran into some problems too.

Okay, Box couldn’t do EFI …

Please format the disk again and adjust (e.g. leave them off) my achievements regarding

  • /boot and
  • /boot/efi

on the empty disk create

  • a MBR
  • Device type : Partition
  • Filesystem: BIOS Boot
  • a boot disk
  • Device type: Partition
  • Size: 1 GB
  • Filesystem: ext4
  • Label: BOOT
  • mountpoint: /boot

for the Brtfs Volume: same as before

It would be easier to just do an auto partitioning install than to manually create what the user thinks would be the correct partitions.

To each their own of course, but for simplicity an auto install manages it all quite well.

When doing it manually it would require (as you note) the bios boot, /boot with ext4, and then btrfs for HOME and ROOT subvolumes.

that wasn’t my impression, so I tried to circumvent it …

+++ EDIT +++
circumvent the OP’s trouble cit: "got stuck on “Installing boot loader

If auto partitioning did not work well for everyone the fedora team would have been slammed with problem reports. The auto install method has been in use for many many moons with few or no problem reports.

I have never seen any issues with it though it is possible that some small percentage of users might. I routinely install VMs with the auto partitioning method and when I reinstall a host I often do the same.

if the SSD is still fit

check with

sudo smartctl -a /dev/sd_X

adjust “sd_X” with the correct drive (should be sda when the ssd is alone in the box)

values and the meaning (scroll down to “Known ATA S.M.A.R.T. attributes”)
esp.: “173” SSD Wear Leveling Count

I’m running Red Hat/Fedora since 6.3/core 1 !
~20 years … and I’m in the IT since ~30 years

what do you want to tell me ?

btw: Over Provisioning isn’t handled by auto install …

I thought I said it.

what you thought and what others think might be different !
anyway: help the OP, that the best practice !