Stuck in Activities Overview and can't escape

I’ve run into an issue where once entering the Activities Overview, I can’t get out of it. I’ve tried clicking Activities in the top corner, clicking on an application, searching for an application and hitting enter, every keyboard combination I can think of (Esc, Super, Super+S), my gesture shortcut, etc. to no avail. And while I’m in the Activities overview, I can’t use anything – I’m able to launch new programs using keyboard shortcuts (for instance, opening a Terminal window or a folder with Nautilus), but I cannot click anything or type anything into them.

I’m on Fedora 34 Workstation using Gnome 40.4.0, and I usually use the X11 window manager but I was having the same issue in Wayland. The issue started this morning after I ran sudo dnf upgrade. I ordinarily use the Vertical Overview GNOME extension, but that seems to be what’s causing the issue – once I disabled the extension, things are back to working normally. So the short-term fix seems to be “stop using the Vertical Overview extension,” but I strongly prefer to have my workspaces oriented vertically.

Anybody have thoughts on what might be causing the issue, or how I might go about solving it?

1 Like

According to your description, the extension is causing the issue.
Best would be to report it to the author(s) of the extension and disable the extension until the bug is fixed.

Extensions are the number 1 cause for issues in Gnome. In terms of stability, the best is to disable all extensions

1 Like

That makes sense, that’s probably the most straightforward solution. I’ll submit a report, thanks!

The important bit is that not all extensions are developed by the Gnome developers. So it’s best to file an issue with the extension developer.

I don’t, at a glance, see an issue for this yet, so really good to do that:

1 Like


I think it was already updated in Fedora based on the comments.