GNOME 40 opening desktop instead of Activities

I’ve read that one of the changes in GNOME 40 is that after login the Activities overview comes up. But I’m still getting the empty desktop as I’m used to from previous GNOME versions. Is this a known bug or it’s just me?

I’m running Fedora 34 prerelease Silverblue:

$ rpm-ostree status
State: idle
● ostree://fedora:fedora/34/x86_64/silverblue
                   Version: 34.20210310.n.0 (2021-03-10T08:08:04Z)
                BaseCommit: cf49f926a86b821eb56d029274025833e97638b909e79495ca42559513ef3064
              GPGSignature: Valid signature by 8C5BA6990BDB26E19F2A1A801161AE6945719A39
           LayeredPackages: libinput-utils

It should be the empty desktop but zoomed out to the overview, where you can start typing…

1 Like

It’s not zoomed out: I have to press the Super key, then I can see the dash or start typing.

How to debug it?

$ rpm -q gnome-shell

I’d start by creating a new user to see what happens there.

Is this on Silverblue, by the way, since we’re in the SIlverblue category here?

Do you have any extensions installed?

I’ve created a new user and I can reproduce the problem.
I have only Background Logo extension enabled and disabling it did not help.

Yes, I’m on Silverblue (see my first message).

I’ve just installed GNOME OS nightly in Boxes and I can reproduce the same issue.
Can anybody confirm? Looks like a gnome-shell issue?

I rebased to F34 and Gnome boots into desktop Instead of activities for me also.

After upgrading GNOME OS today, now it boots in activities. Settings shows GNOME version 40.rc.

Hopefully this will be It is fixed in F34 as soon as it’s upgraded to GNOME 40.rc.

1 Like