Strange behaviour of PC after shutdown

Hello, I dont really know how to explain this,

TL;DR : Every time i shutdown my PC in the evening i find my PC in the morning in sleep mode.

I run Fedora 38 (workstation, KDE wayland, Kernel: 6.4.12-200.fc38.x86_64 (64-bit) ) in a dualboot system with Windows 10.

For a week now i am using Fedora as my main operating system, every time i shut my PC down i find the powerbutton led flashing and the led on my external drive on. When i tap on my space bar it seems that my PC was in sleep mode.

I have tried different ways of shutting down my PC (commands line, trying stuff in settings, changing the behaviour of the powerbutton) but every time i find my PC in sleep mode in the morning.

i did a short test during the day and it didnt went from shutdon mode to sleep mode, so the PC only switches from mode after a long/predefined time or the PC switches at a certain time during the day…? or it is something simple that i don’t see.

if anyone knows more please help me, i dont like my PC being on when i dont need it.

Kind regards, thank you

Please provide the details of how you do the shutdown. As they say, “the devil is in the details”.
Without a detailed description of the steps followed to perform the shutdown it is difficult to even follow what may have been done. “i shut my PC down” seems repeated several times but never with a step by step description.

I use the icon at the upper right (on gnome) and it gives me a button to power off. That should do the same for you. From the command line sudo shutdown -h should also power the system down.

You said you are dual booting with windows. Is windows shutdown or was it suspended or sleeping. Note that a full shutdown on windows should not interfere with Fedora, but having windows in fast boot, sleeping, or otherwise not fully shutdown might cause problems with fedora. Especially if either windows or fedora are set to auto boot on a timer.

shutdown procedures i have used so far:

  • pressing the “shut down” button on the log-out screen (in KDE)

  • shutdown by pressing on the power button on my PC

  • using the command sudo shutdown now --poweroff

all 3 options give the same result

Fedora is in control of the dualboot (via grub), when i shutdown windows the fedora logo appears for a short second, so far i have always immediately switched from windows to fedora and fedora is so far always my last os of the day.

I will try the sudo shutdown -h command today.

Next time it happens, can you see what the system uptime is (run uptime) and thus see what time it started itself?

And… is there any setting set to wake on LAN, wake on power status change etc set in the BIOS/firmware?

Try systemctl poweroff or if in gnome gnome-session-quit --power-off. There is also a setting in the power management for selecting power button behaviour. It is usually standby I think.

not needed, on 23:00 i shutdown the PC with command sudo shutdown -h, the PC shut down like any other PC, however at 00:00 (midnight) i saw the computer boot up to perform an update.

in the logs application of fedora i found a log explaining that the PC performs various updates, updates about fedora itself and the kernel, no software. the updates ended at 00:02:35. However I don’t really understand what triggers or orders the reboot/updates.

I set mine to shutdown.

so i guess my next question is, how do i disable auto updates and rebooting on its own?

When you type shutdown -h this is an alias for systemctl poweroff. Systemd is the system manager on Fedora, not sysv.

Auto updates are disabled in Gnome Software, and Fedora does not reboot on it’s own unless you configured it to. It always prompts/notifies of pending updates to install.

where can i find these configures for auto booting and update?

Open Gnome Software
Preferences are in the “hamburger menu”
Select Preferences
Select appropriate toggle

That was surprisingly easy
thank you

You’re welcome. Could you please mark the appropriate comment that was your solution? This will help the next community member who has a same issue.

Tonight i will give your solution a try, if it works i will make a short update and mark the solution.
It is not that i don’t believe you, i just want to be sure :slight_smile:

It’s always good to test a concept before declaring it valid.

Is Fast boot enabled in your BIOS? If so, try disabling it.

Also, the default windows shut down, puts the system to a semi sleep mode. I don’t know, but this might interfere with you Fedora install.

Going right along with this note, is the fact that if windows is set to wake up and do updates it also could interfere with a normal full shutdown and cause restarts since windows would then be only in standby and not fully shut down.

The linux last command may also provide clues since it tells when a system is shutdown, started, when the user logs in, with dates, times, kernel versions, etc.

If you do a clean shutdown then find it not fully shutdown the next time you check, that command may provide some related info.


changing the settings in GNOME Software sadly didn’t work, the PC still rebooted itself at midnight, updated and went to sleep (sleep is disabled, it just waited).

I used the lastcommand, this is the result:

There is no wake on LAN option enabled, I havent found any wake on power status change settings, regarding the uptime command:

Fast boot (or similar) option not found

something interesting (that might be unrelated): in the BIOS i found “BIOS Power-On” option
in this option (i think) you can choose when the BIOS gets powered on, all seven days of the week have the enabled flag and the time is set to 00:00. This BIOS option is now completely disabled.

That may indeed be the culprit. Is this a server type board? Just curious since I haven’t ever seen an option like that in mine, maybe I should do some digging. :thinking:

1 Like

My motherboard is a “sunflower” motherboard by HP (link).

picture of the BIOS setting:

I have them all disabled now. :^)
I also haven’t seen much info about this “BIOS Power-On” setting on the internet.

That definitely looks like the cause!

Please, in the future try and post text from your screen with copy & paste using the preformatted text tag (the </> button on the toolbar). Images cannot be searched nor data from them easily quoted.

Using text posts makes it easier for those helping you and also makes it possible for others searching later when they may have similar problems to find answers that may have helped you.
Obviously the screenshot from bios required a pic, but almost everything else could have been copy & pasted – including the screenshot from the last command which only showed the last 2 boots.