Steelseries Arctis Pro - Microphone no longer working on Fedora 34

After upgrading to Fedora 34 my Steelseries Arctis Pro headset, connected to a USB port, worked properly. Some recent update however introduced a problem with the microphone. Although the system recognises that it exists and can be used, there is no sound input even if I increase the level to the maximum value.

Is anyone else having the same problem? Any solutions?

1 Like

Please try this:

I’ve had a similar problem with outputs.
Does restarting pipewire change your indications
systemctl --user restart pipewire*

You might also want to check these


1 Like

Hello, I have the exact same issue, the problem isn’t with Output but the Microphone (input).
The microphone is detected as an input just fine, but it just doesn’t pick anything up.

I’ve read through and tried the steps in both links in the replies here but they did not work.

I also tried these commands to swap back to pulseaudio along with reboots but this also did not work.

The steps in the arch wiki aren’t helpful as I don’t have /etc/pipewire
(cannot post link because new user)

Yes, the service is running ok and I have ok Output.

Yes we already had a discussion here about the missing /etc/pipewire directory. You can find the the default config files in /usr/share/pipewire and copy them to /etc/pipewire (see top of *.conf file)

# Copy and edit this file in /etc/pipewire for systemwide changes
# or in ~/.config/pipewire for local changes.

A tip, to find config files for an executable:
$ whereis pipewire