Fedora 35 doesn't detect microphone bluetooth headset

Bluetooth headset connected to fedora for input microphone, but pulseaudio does not detect microphone, only output worked.


 javad@fedora  ~  arecord -l                      
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC270 Analog [ALC270 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

 ✘ javad@fedora  ~  pacmd list-cards
2 card(s) available.
index: 1
	name: <bluez_card.41_42_63_FD_96_5A>
	driver: <compiler_depend.ts>
	owner module: 20
		device.description = "WS-H07"
		device.string = "41:42:63:FD:96:5A"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "headphone"
		bluez.path = "/org/bluez/hci0/dev_41_42_63_FD_96_5A"
		bluez.class = "0x240418"
		bluez.alias = "WS-H07"
		device.icon_name = "audio-headphones-bluetooth"
		a2dp_sink_sbc: High Fidelity Playback (A2DP Sink: SBC) (priority 40, available: yes)
		a2dp_sink_aac: High Fidelity Playback (A2DP Sink: AAC) (priority 40, available: no)
		a2dp_sink_aptx: High Fidelity Playback (A2DP Sink: aptX) (priority 40, available: no)
		a2dp_sink_aptx_hd: High Fidelity Playback (A2DP Sink: aptX HD) (priority 40, available: no)
		a2dp_sink_ldac: High Fidelity Playback (A2DP Sink: LDAC) (priority 40, available: no)
		headset_head_unit: Headset Head Unit (HSP/HFP) (priority 30, available: no)
		off: Off (priority 0, available: yes)
	active profile: <a2dp_sink_sbc>
		bluez_sink.41_42_63_FD_96_5A.a2dp_sink/#1: WS-H07
		bluez_sink.41_42_63_FD_96_5A.a2dp_sink.monitor/#2: Monitor of WS-H07
		headphone-output: Headphone (priority 0, latency offset 0 usec, available: yes)
		headphone-input: Bluetooth Input (priority 0, latency offset 0 usec, available: no)

 ✘ javad@fedora  ~  sudo dnf list installed | grep '\(pipewire\)\|\(pulseaudio\)'
pipewire.x86_64                                   0.3.40-1.fc35                          @updates                        
pipewire-alsa.x86_64                              0.3.40-1.fc35                          @updates                        
pipewire-gstreamer.x86_64                         0.3.40-1.fc35                          @updates                        
pipewire-jack-audio-connection-kit.x86_64         0.3.40-1.fc35                          @updates                        
pipewire-libs.x86_64                              0.3.40-1.fc35                          @updates                        
pipewire-utils.x86_64                             0.3.40-1.fc35                          @updates                        
pulseaudio.x86_64                                 15.0-2.fc35                            @fedora                         
pulseaudio-libs.i686                              15.0-2.fc35                            @fedora                         
pulseaudio-libs.x86_64                            15.0-2.fc35                            @fedora                         
pulseaudio-libs-glib2.x86_64                      15.0-2.fc35                            @fedora                         
pulseaudio-module-bluetooth-freeworld.x86_64      1.4-8.fc35                             @rpmfusion-free                 
pulseaudio-utils.x86_64                           15.0-2.fc35                            @fedora                         
wine-pulseaudio.i686                              6.21-1.fc35                            @updates                        
wine-pulseaudio.x86_64                            6.21-1.fc35                            @updates  

I try for this PulseAudio/Troubleshooting - ArchWiki but doesn’t work.

Please help me microphone important for me.

1 Like

No one has a suggestion?

hi @ja7ad You know of the pulseaudio/ pipewire change? PipeWire: the new audio and video daemon in Fedora Linux 34 - Fedora Magazine
I suppose you are on fedora workstation?

From Gnome setting, on Output, change the Configuration to anything mentioning headset. Since you current setting only set as a playback, it will only act as playback (output only).

Note, sometime it will take sometime to it to be applied. In my case sometime the bluetooth need to reconnect again.

Hey there, I’m having this same issue. I have a bluetooth speakerphone that plays my sound, but it’s microphone abilities are being completely ignored by the system.

Any ideas? Thanks!

there are different codecs for Bluetooth audio playback.
If I understand it correctly, in order to improve the sound quality, some codecs/profiles give up the other direction - which is the microphone.
To use a headset for both listening and speaking, you need to choose the right codec/profile for transmitting bi-directional audio to and from Bluetooth headsets.

Open your sound settings, choose headset as Output Device and see what you have in Output > Configuration.

In my case HSP/HFP, codec mSBC works well.

thank you

Hey Guys, Any suggestion to solve this issue ?
I have same problema and chose HSP/HFP, codec SBC not work for me.
Sound system still not detect my headset mic

My problem was solved.

Running systemctl --user status pipewire-media-session I’ve got:
Unit pipewire-media-session.service could not be found.

Then , enable pipewire and disable pulse:
sudo dnf install --allowerasing pipewire-pulseaudio
systemctl --user start pipewire-pulse.service pipewire-pulse.socket

With my user I was able to run systemctl --user status pipewire-media-session
and connect my audio is back and microphone bluetooth headset was detected.

Source: Pipewire doesn’t actually recognize any Sound outputs (devices)

1 Like

Much kudos & good karma to you.
This worked perfectly for me after problems when upgrading to F36.