Microphone doesn't work

I have 2 USB web cameras with built-in microphones.
They worked great for years.
After upgrading to F35, the built-in microphone doesn’t work.
It appears as Input Device in Gnome Settings panel.

I haven’t any custom configuration, modules, etc, so I believe that is related to the changes that happened with PipeWire/WirePlumber on F35.

Are there any suggestions to troubleshoot it before I open a bug report?

Please follow the last link on the change set.
Releases/35/ChangeSet - Fedora Project Wiki

1 Like

After the pipewire and wireplumber switch, it is common to have to revisit configurations. I found that Gnome settings had more listed I/O for my media than what I was used to prior, or more appropriately listed the items differently. But it did find them all and they work, so I would start there. https://pipewire.pages.freedesktop.org/wireplumber/running-wireplumber-daemon.html has some good info about Wireplumber with Pipewire.


dnf swap wireplumber pipewire-media-session fixed it for me.

I will check out that article as well.