Steam display Chinese garbled characters

I downloaded steam from the software store and set up the Chinese interface, but all Chinese characters were garbled, including Japanese and Korean.

I am using fedora39 workstation.

截图 2023-11-28 18-35-21

You are probably missing this fonts. That’s why the squares are showing up.

Did you see this on Steam? :

I have installed ‘langpacks-zh_CN‘, which includes ‘google-noto-sans-cjk-vf-fonts‘, only Steam does not display properly.

I thought it might be a variable font issue, someone successfully solved it by uninstalling ‘google-noto-sans-cjk-vf-fonts’ and then installing his immutable version ‘google-note-sans-cjk-fonts’ (IDEA seems to have this problem too)

These prompts appeared when I used dnf to uninstall ‘google-noto-sans-cjk-vf-fonts’, I’m not sure if I want to continue, I’m worried about breaking my fedora.

 软件包                           架构      版本              仓库         大小
 google-noto-sans-cjk-vf-fonts    noarch    1:2.004-5.fc39    @updates     31 M
 langpacks-zh_CN                  noarch    4.0-9.fc39        @fedora     425  
 default-fonts-cjk-sans           noarch    4.0-9.fc39        @fedora     2.2 k
 langpacks-core-zh_CN             noarch    4.0-9.fc39        @fedora     423  
 langpacks-fonts-zh_CN            noarch    4.0-9.fc39        @fedora     366  

移除  5 软件包

Is there anything wrong with doing this? After I uninstall, can I still install the font version of ‘google-note-sans-cjk-fonts’ to fix it?

Unfortunately we do not read chinese … can you please repeat the command with:

LANG=C in front of the command. So everything should be in English. Please also past the command which creates the output.

You might change your default language to English before removing the Chinese font. Otherwise you probably just get the squares as in Steam.

I’m familiar with Japanese, not Chinese, but to answer one question, yes, you can reinstall a font after removing it, with
dnf install <fontname>
(I should add that I’m not familiar with using steam). Also, in my .bashrc, I also have LC_CTYPE set to en_US.UTF-8 which has sometimes helped when getting Japanese to work. So, even if the default language is English, Japanese will show properly, in my use case.

@L.S Using google translate seems to indicate the Chinese is saying removing unused dependencies and removing unneeded packages)

1 Like

@ilikelinux @scottro Thank you very much for your answers.

I removed the ‘google-noto-sans-cjk-vf-fonts’ and related dependencies in the English environment, then installed ‘google-noto-sans-cjk-fonts’ and switched back to the Chinese environment. In the end Steam displayed correctly and everything worked fine.