Chinese Font is fixed to a less readable version after updated to F36

I have two devices using Fedora Plasma, a thinkpad laptop and a desktop. I updated the laptop to F36 immediately when it was released, everything was ok. There was a dependency problem unfixed for my desktop at that time, so I waited till last night to update my desktop.

However, after the update, (which I think due to the changing made to default font), all Chinese characters (maybe all CJK) was shown in an unusual font on my desktop ). I then tried to set the font explicitly to CJK version of Noto Sans as follow:

Now, the font works normal in some software (Kmail, firefox, etc) as follow :

But, in several software, e.g. Telegram, Steam, Calibre, the font is still using the unusual one
which is far less readable.

Since none of these issues appeared on my laptop which should be exactly the same, I am really confused at the moment.

For convenience of testing, the string I used in above picture is
我最喜欢的系统是fedora (My favorite OS is fedora)

1 Like

I would venture a guess that these are installed from Flatpak (as I don’t think Telegram is packaged in Fedora)? These would not necessarily have access to the system fonts depending on the sandboxing employed. It is also possible that you may need to update the flatpak runtime with flatpak update as that is independent of the system upgrade.

1 Like

I don’t use flatpak (doubled checked that flatpak list returns nothing)

Actually, both telegram and calibre is installed from dnf (telegram-desktop and calibre)

Ah, I forgot to check RPMFusion.

One thing you can try is logging in as a completely new user and see if that works fine. Then we can narrow down if it’s some sort of user config file.

I tried a new user and no luck.
I find out that Telegram force uses Open Sans as its font, maybe it is also the case for steam and calibre.
I now suspect that these software all have their font choice that overrides system font, and the font they choose (for example Open Sans) don’t have CJK font, and uses some fallback default font, which is changed after the system update. (I believe something about font was mentioned that cannot be updated during the check before update, I shouldn’t ignore it)

However nothing wrong happened on my laptop, which should have almost the same configuration, except the first fedora I installed on desktop was f30, while on my laptop it was f34.

Application not written for KDE i guess. Some GTK issues.
On the Gnome desktop you could try to set this with the gnome tweaks > Legacy Applications.

This fixes calibre! Thank you!

But telegram and steam is still not working. I believe it is CJK is not supported in their specified font, and during the update the origin fallback font is lost. Is there a way I can export a full detail list about condition of fonts and usage on my OS? If I can then I can compare my laptop and desktop to find out the problem.

Installed as flatpak right? You might have to investigate between flatpak and your local machines fonts. I saw some old topics who shows that some fonts can interfere with local fonts.


Well please kindly look at

I don’t think it is the problem

Try going to this site. Maybe it’ll help you with whatever issue you maybe facing with font rendering. Help:Multilingual support - Wikipedia

Your system is trying to use a fallback font, and it seems like it’s confused on what font it wants to use. Try identifying the fonts that are being used and mess with how the system uses them (i.g, installing or uninstalling fonts.)