SpeedMind M-BOOK laptop: right-click on touchpad detected as left-click

I have a laptop branded as “M-BOOK” by “SpeedMind”, with 4 GB RAM and two solid state drives. This laptop came pre-installed with Windows 10, but now has a dual-boot setup with Fedora 39 booting as the default OS. I can choose to boot back into Windows 10 in order to compare behaviors.

This laptop has been repeatedly upgraded through several Fedora versions. Since upgrading to Fedora 39, I have noticed that the lower right touchpad corner that is supposed to provide the right-click instead gives a left-click, just like the lower left touchpad corner.

On this laptop, the touchpad is a flat rectangular surface, but the lower left and right corners can be physically depressed in order to provide the mouse left and right-clicks. The surface at the corners, when not depressing them, makes the cursor move when sliding the fingertip around, just like the rest of the touchpad surface.

When booting into Windows 10 during tests, the left and right corners behave correctly as left and right click, respectively.

When booting into Fedora 39 into the GNOME 45 desktop, I realized that, although the left corner behaves correctly as left-click, the right corner (incorrectly) reports a left-click when depressed. So I effectively have two left-click buttons.

I have tried searching in this forum looking for configuration solutions to this issue, but to no avail:

  • In the standard touchpad configuration, I have enabled and disabled the “touch to click” option. No change.
  • In gnome-tweaks, I had the “fingers” option for registering the right-click through the touchpad. Just in case, I tried tapping the touchpad with two fingers - no dice, it does not work at registering a right-click. So I changed it to “area” and tried tapping the right corner, and also depressing the right corner - it still registers a left-click
  • I tried changing the option to “disabled” - lower right corner still reports a left-click when depressed.

Just in case, if I connect an USB mouse, it correctly detects the mouse left and right clicks as normal. However I do not always have a mouse available.

I now ask for help because this starts looking like an actual bug specific to my touchpad hardware. Remember - Windows 10 does detect both left and right clicks, so this is not a hardware issue. What else can I try to diagnose or fix the issue?

I have now tried to install Weston as a separate desktop environment from GNOME and tried the right click there - still detected as left-click.

After a bit of digging, I have confirmed that this is a regression in the libinput package from version 1.24.0-1 to 1.25.0-1. There is a libinput quirk defined at /usr/share/libinput/50-system-graviton.quirks (file introduced in 1.25.0-1) that happens to match my touchpad too, resulting in no right click detected. My workaround is to move aside the file, and now a right click is indeed detected when depressing the bottom right corner. I will now report a bug to the project.