Speakers sound doesn't work in fedora 37 Kernel: 6.1.10-200

Hello everyone, I ask for help with troubleshooting sound problems.
I bought a new asus vivobook pro 15 laptop and installed windows 11 dual boot along with fedora workstation 37.
on fedora i updated all packages, sound drivers are installed by default pipewire and wireplumber.
But the sound in the speakers does not work for me.
I tried to check on the headphones via bluetooth and everything works with the headphones.
I googled and tried many solutions, but to no avail.

We’re having a very similar problem. It seems the laptop can detect HDMI audio devices, but not the built-in laptop mic/phones. It started happening suddenly after some upgrade. Did you find the problem source? Or any clues?

I looked on the forum, but no. Didn’t find suitable solutions

Hi Alish and Jairo,
I got the same issue, after updating my Fedora, the audio devices disappeared from the “available ones” in the list. I’ve tried different approaches and here is the one it worked for me.

Try running these 2 commands:

fwupdmgr get-devices | grep "Management Engine" -A 10 | grep "Device ID:"
fwupdmgr reinstall <Intel ME id>

NOTE: When doing it, my laptop got stuck in a black screen on the startup process for at least 5-7 minutes, be patient and don’t force-shutdown.

1 Like

Hi Ezequiiel, i don’t have Management Engine in list when i run fwupdmgr get-devices and your answer didnt work for me. but thanks anyway

Hi Jairo, I find solution and speakers now work.
Solution find here 206289 – No sound on ASUS Zenbook UX533FTC (comment in bottom f25

Second command works