No sound from built in speakers, fedora 38

I’m running Fedora 38 and started having audio issues with a system update.
My other audio devices like bluetooth headphones/speakers seem to work fine, but the built in speakers do not produce any sound. Nor do my wired headphones using the 3.5mm jack.

Moreover, since I dual boot Windows, I was able to verify that the hardware is fine since the speakers work just fine on Windows. I’ve tried following the advice on many different threads but none have fixed my issue so far.

Here’s some information about my laptop:

OS: Fedora Linux 38 (Workstation Edition) x86_64 
Host: HP Spectre x-360
Kernel: Linux 6.4.12-200.fc38.x86_64 x86_64
CPU: 8th Gen Intel i7-8750H
GPU: Nvidia GeForce GTX 1050Ti Max Q

Here’s a snippet from the file generated by --no-upload

!!ALSA Version

Driver version:     k6.4.12-200.fc38.x86_64
Library version:    
Utilities version:  1.2.9

!!Loaded ALSA modules

snd_hda_intel (card 0)
snd_soc_skl_hda_dsp (card 1)

!!Sound Servers on this system

      Installed - Yes (/usr/bin/pipewire)
      Running - Yes

No sound servers found.

!!Soundcards recognised by ALSA

 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xb5080000 irq 17
 1 [sofhdadsp      ]: sof-hda-dsp - sof-hda-dsp

!!PCI Soundcards installed in the system

00:1f.3 Multimedia audio controller [0401]: Intel Corporation Cannon Lake PCH cAVS [8086:a348] (rev 10)
	Subsystem: Hewlett-Packard Company Device [103c:8519]
01:00.1 Audio device [0403]: NVIDIA Corporation GP107GL High Definition Audio Controller [10de:0fb9] (rev a1)
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-

I’ve tried systemctl --user restart pipewire and systemctl --user enable --now wireplumber without any luck.

Any help is greatly appreciated!

Here’s some more info:

❯ inxi -A
  Device-1: Intel Cannon Lake PCH cAVS driver: sof-audio-pci-intel-cnl
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
  API: ALSA v: k6.4.12-200.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.79 status: active

❯ pipewire --version
Compiled with libpipewire 0.3.79
Linked with libpipewire 0.3.79

Hello @nutshell7984 and welcome to ask :fedora:

Have you searched for others with similar problems here?

One of the most common fixes seems to be install pavucontrol and use it to select the device and set the volumes there.
It may also be necessary to select the sound device in the gnome settings control panel.

One thing I have found is that if you plug in an external monitor the laptop may try to select the nvidia audio for output – the one noted in your inxi output as Device-2 – and if it does that then no sound will come out of the speakers or headphones. That device routes the audio out to the monitor speakers instead.

Surprisingly, a system update fixed the issue. I think it updated the drivers I had for the speakers and that was it!