No sound from speakers on Alder Lake

I’ve installed F36 and then F37 Beta on my new Huawei Matebook 16s running on Alder Lake but I don’t have sound coming out from the speakers.

The sound card is rightly detected.

If I open the alsa mixer and enable the sound for headphones or connect some headphones then the sound comes from the speakers.

[ajsantos@fedora ~]$ inxi -Fzxx
  Kernel: 5.19.12-300.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-24.fc37 Desktop: GNOME v: 43.0 tk: GTK v: 3.24.34 wm: gnome-shell
    dm: GDM Distro: Fedora release 37 (Thirty Seven)
  Type: Laptop System: HUAWEI product: CREF-XX v: M1010
    serial: <superuser required>
  Mobo: HUAWEI model: CREF-XX-PCB v: M1010 serial: <superuser required>
    UEFI: HUAWEI v: 1.20 date: 07/27/2022
  ID-1: BAT0 charge: 24.4 Wh (29.0%) condition: 84.1/82.9 Wh (101.5%)
    volts: 11.2 min: 11.5 model: Sunwoda-H HB9790T7ECW-32 serial: <filter>
    status: discharging
  Info: 14-core (6-mt/8-st) model: 12th Gen Intel Core i7-12700H bits: 64
    type: MST AMCP arch: Alder Lake level: v3 rev: 3 cache: L1: 1.2 MiB
    L2: 11.5 MiB L3: 24 MiB
  Speed (MHz): avg: 2460 high: 2700 min/max: 400/4679:4700:3500 cores:
    1: 2700 2: 2700 3: 1149 4: 1056 5: 2700 6: 2700 7: 2700 8: 2700 9: 2700
    10: 1114 11: 2700 12: 2700 13: 2700 14: 2700 15: 2700 16: 2700 17: 2700
    18: 2700 19: 2700 20: 2700 bogomips: 107520
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Huawei
    driver: i915 v: kernel arch: Gen-12.2 ports: active: eDP-1 empty: DP-1,
    DP-2, DP-3, HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:46a6
  Device-2: Sonix Integrated Webcam_FHD type: USB driver: uvcvideo
    bus-ID: 3-7:2 chip-ID: 3277:0004
  Display: wayland server: v: 1.20.14 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: BOE Display 0x092f res: 2520x1680 dpi: 189
    diag: 407mm (16")
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.2.0
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Huawei
    driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3 chip-ID: 8086:51c8
  Sound Server-1: ALSA v: k5.19.12-300.fc37.x86_64 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.59 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:3
    chip-ID: 8087:0033
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 44.29 GiB (4.6%)
  ID-1: /dev/nvme0n1 model: PCIe-8 SSD 1TB size: 953.87 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 35.9 C
  ID-1: / size: 767 GiB used: 43.95 GiB (5.7%) fs: btrfs dev: /dev/nvme0n1p6
  ID-2: /boot size: 973.4 MiB used: 271.4 MiB (27.9%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-3: /boot/efi size: 96 MiB used: 73.1 MiB (76.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 767 GiB used: 43.95 GiB (5.7%) fs: btrfs
    dev: /dev/nvme0n1p6
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 37.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 402 Uptime: 56m Memory: 15.35 GiB used: 4.79 GiB (31.2%)
  Init: systemd v: 251 target: graphical (5) default: graphical Compilers:
  gcc: 12.2.1 Packages: pm: rpm pkgs: N/A note: see --rpm pm: flatpak pkgs: 7
  Shell: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.21

Note: I’ve tested Ubuntu 22.04.01 LTS live and the speakers work as normal.

Using a live usb for F36 the sound works with kernel 5.17.5. Seems like something got broken.

That tells me the sound is working.

Have you tried pavucontrol to set and enable the outputs? It would seem the system is improperly recognizing the outputs and needs to be tweaked for the proper sinks.

That seems the problem, the sound is not being sent to the speakers. On pavucontrol it is all well configured.

But as I said earlier, on Ubuntu or F36 Live USB it works well.

Seems that this is somewhat related: No sound after fresh install - XFCE / Alder Lake / Multiple kernel versions - Sound - Manjaro Linux Forum

Hi, i have the same problem over arch, i filed a bug report at this link Bug report, if you want to try the same stuff that i have tried maybe you are luckier than me. From the test that i have done the audio problem was still present , in a different flavor, in the normal Ubuntu 22.04 with the base kernel 5.15 (as i explained in the bug report). Moreover i don’t think is problem related to the sinks but just a wrong software miss-configuration of the pin, since if you use hdajackretask the 0x16 are defined as the headphones but is actually the speaker and the 0x17 is defined as speaker but they are actually the headphones. The audio with the Bluetooth at least works fine :grin:

1 Like

Hi, @tomawock looks like you are correct in KDE if I set the output to Headphones it will play sound, but only in KDE in browsers or other applications like Spotify still doesn’t work.

Hi all,

I am experiencing the same issue with Fedora 37 on an HP Elitebook 840 G9 and the kernel 6.0.8.

The sound card seems correctly detected but I cannot manage to hear sound from the speaker. This works when using windows.

Thanks if anyone has any update on this issue.

1 Like

I just registered to say I have exactly the same problem but with HP Elitebook 860 G9.

Analog headset works pretty well but speakers produce nothing. Pavucontrol shows some alive audio level on speakers but I hear just silence.

On my side the bug has disappeared recently, at least with the linux kernel 6.0.16.

Cool! Could you show everything related to audio from your dmesg?
I built kernel 6.1.4 manually. But maybe I missed something.
Also I don’t have dual-boot with Windows, but I heard a lot like rebooting to Windows may fix audio in Linux too.