Sound stopped working after f37 upgrade

My sound stopped working after I upgraded to f37. This is a KDE spin. Prior to this I never had a problem with sound going several versions.

There have been other posts with similar problems but after an upgrade to f35. I have tried some of the steps in these other posts that suggest switching back to pulseaudio but nothing has worked.

When I log into my user account there are a series of pops from the speakers and the speaker icon on the task bar has the red strike through (as if muted) and there are no playback devices detected. I can open the audio setting and click “Show Inactive Devices” and a playback device is displayed but no sound when I try the Test button.

Here is some system info:

lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)

dmesg | grep audio
[ 18.991573] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 19.397318] snd_hda_codec_realtek hdaudioC0D2: ALC662 rev3: SKU not ready 0x411111f0
[ 19.397693] snd_hda_codec_realtek hdaudioC0D2: autoconfig for ALC662 rev3: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[ 19.397701] snd_hda_codec_realtek hdaudioC0D2: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 19.397704] snd_hda_codec_realtek hdaudioC0D2: hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[ 19.397707] snd_hda_codec_realtek hdaudioC0D2: mono: mono_out=0x0
[ 19.397709] snd_hda_codec_realtek hdaudioC0D2: inputs:
[ 19.397711] snd_hda_codec_realtek hdaudioC0D2: Rear Mic=0x19
[ 19.397714] snd_hda_codec_realtek hdaudioC0D2: Front Mic=0x18
[ 19.397716] snd_hda_codec_realtek hdaudioC0D2: Line=0x1a

The “SKU not ready…” is a concern and a google search shows similar problems but nothing recent and the solutions are to modify /etc/modprobe.d/alsa.conf. My system doesn’t have that file. Is that a problem? If I need that file how do I restore it?

I’m not sure where to go from here and what may have changed between f36 and f37.

Thanks for any help,

I wonder if my problem is related to this

issue with the kernel. The oldest kernel version I have available on my system now is 6.1.6. I’ve never tried to revert to an older version with Fedora. I’ll have to figure that out and I may give it a try.

We are already on 6.1.8-200.fc37.x86_64 try to upgrade.

Or before you can open the alsamixer and see if you have a volume, you can rise up.
Sometimes the Speaker and or Headphone are wrong labeled. And one of them is on minimum alias off.

I think I didn’t explain my position very well. I am currently running 6.1.8-200.fc37.x86_64 and my system is up to date. The link I posted implies there is a problem with 6.1.x kernels. I wanted to find out if I can install and run an older kernel perhaps a 6.0.x version.

I have volume when I run alsamixer but no sound.

By the way how does alsa, pipewire, and wireplumber work together? What does each component do?

I made a new topic for that: