Somebody save me! REST package broken, cannot open gnome-control-center

Hello! After upgrading to Fedora 37 from Fedora 36 (via system-upgrade plugin), Nautilus just wouldn’t open. So, I downgraded back to Fedora 36 (via system-upgrade plugin). But now, gnome-control center won’t open too. It looks like the problem revolves around this REST package, so I tried to reinstall it. Then, I got the error message shown below. It somehow “stuck” to the Fedora 37 version and I cannot just remove it and install the correct version because of another DNF error (it would break gnome-shell).

What should I do? Help me!

Gnome-control-center error message

/usr/libexec/gnome-control-center-goa-helper: error while loading shared libraries: cannot open shared object file: No such file or directory

(gnome-control-center:47664): GLib-CRITICAL **: 13:31:19.906: g_variant_parse: assertion ‘text != NULL’ failed
Segmentation fault (core dumped)

DNF Error message:

Error: Transaction test error:
file /usr/lib64/ from install of rest-0.8.1-12.fc36.x86_64 conflicts with file from package rest0.7-0.8.1-2.fc37.x86_64
file /usr/lib64/ from install of rest-0.8.1-12.fc36.x86_64 conflicts with file from package rest0.7-0.8.1-2.fc37.x86_64

Is the control center the only obvious problem?
If it is then try sudo dnf distro-sync --refresh --allowerasing to see if there may have been an error in processing the upgrade and if it may be fixed that way.

You also may try sudo dnf upgrade --skip-broken --allowerasing --best --refresh

Thank you for the reply.

Control center is the only obvious problem.

Both commands (distrosync and upgrade) outputs “Nothing to do”


So, I think (?) I fixed it.

First, I unprotected gnome-shell in /etc/dnf/protected.d/fedora-workstation.conf

Then, I logged in to TTY3 and removed the aforementioned REST package using dnf and, finally, reinstalled gnome-shell.

gnome-control-center is back, but I have no idea if my “solution” is really a “solution” :laughing:

There have been strange instances where distro-sync, upgrade, reinstall, and the like have failed to fix inconsistencies that were then fixed by a removal and install of the affected package. Maybe you were hit with one of those circumstances.

I recall one recently where even a dnf reinstall '*' which should have cleanly reinstalled every package on the machine failed but a removal and install of the failing package fixed it.

It seems sometimes the reinstall does not cleanly fix errors. I suspect that it may be to a simple error of a bit or byte within a file and reinstall simply attempts to overwrite the existing file leaving it at the same inode location in the file system, while removal followed by install actually fully writes the data on new inodes so the clean copy is now OK.

I wonder what type storage media (HDD, SSD, SD card, ?) and what filesystem types this is occurring on? I have no info on that. On fedora I suspect BTRFS for many.

1 Like

Thank you, again.

I thought I flew too close to the sun “removing” REST and gnome-shell and installing them again. But I’m glad things are back to normal now :smile:

In my case, it is SSD/BTRFS