Some Raspberry Pi boards have no display output on Fedora Server


Some revisions of Raspberry Pi will have no display output when running Fedora 38/39 Server Edition.


Server images use the firmware-provided dtb (device tree blob/binary) because the kernel-provided dtb cannot be read from XFS filesystem (used on a Server image). Other images use the kernel-provided dtb because they don’t use XFS.

Related Issues

Bugzilla report: #2246428


The bug can be worked around by booting with nomodeset kernel argument.

Fresh installation

You can add --args "nomodeset" argument to the arm-image-installer, like this:

sudo arm-image-installer --image=</path/to/fedora_image> --target=<RPi_Version> --media=/dev/<sd_card_device> --resizefs --args "nomodeset"

Adjusting an existing system

If your system is already installed and don’t want to reinstall it, you can edit the boot entry in the bootloader. In the bootloader, press Ctrl+e to edit the currently selected boot option, find the kernel line and add nomodeset at the end of the line. Finally, boot the system by pressing Ctrl+x. This modification will only apply to the current boot.

If you want to apply the boot modification permanently, edit /etc/default/grub, add nomodeset to line GRUB_CMDLINE_LINUX=, and then run:

sudo grub2-mkconfig -o /etc/grub2.cfg

You can discuss this issue here.


This is fixed in Fedora 40.

1 Like