Fedora rawhide/F40 Kernel

Fresh install of f39 on Raspberry Pi 400 SBC (wok station) now works.
f40/rawhide (Workstation , Index of /pub/fedora/linux/development/rawhide/Workstation/aarch64/images ) , however, after going through the initial booting fails to display the usual setup screen. x86_64 has no such problems for Rawhide/f40.

Any solution ?

Welcome to Fedora @geev03

There where problems with some raspberry boards:

Try the nomodset argument as described as workaround on the link above.


The bug can be worked around by booting with nomodeset kernel argument.

Fresh installation

You can add --args "nomodeset" argument to the arm-image-installer, like this:

sudo arm-image-installer --image=</path/to/fedora_image> --target=<RPi_Version> --media=/dev/<sd_card_device> --resizefs --args "nomodeset"

Adjusting an existing system

If your system is already installed and don’t want to reinstall it, you can edit the boot entry in the bootloader. In the bootloader, press Ctrl+e to edit the currently selected boot option, find the kernel line and add nomodeset at the end of the line. Finally, boot the system by pressing Ctrl+x. This modification will only apply to the current boot.

If you want to apply the boot modification permanently, edit /etc/default/grub, add nomodeset to line GRUB_CMDLINE_LINUX=, and then run:

sudo grub2-mkconfig -o /etc/grub2.cfg