[SOLVED] NFS unsupported in Nautilus

I’m trying to mount NFS share (v3) but Nautilus can’t permit me to use the nfs:// protocol (button disabled)
It’s not a problem on the server side (another devices access files of the NFS without problem)

I’ve tried to install with rpm-ostree libnfs, but this doesn’t works

rpm -q nautilus gvfs libnfs

Any ideas please?

Make sure gvfs-nfs is installed.

1 Like

Yeahh well done!
BTW, there is no command in rpm-ostree to search a package ? On https://rpm-ostree.readthedocs.io/en/latest/manual/administrator-handbook/ they don’t say anything about that. This could be really useful to do a "rpm-ostree search nfs’

EDIT: And if you known where it’s really mounted please, because I can’t use rsync in command line, I need to use Nautilus to copy! The “mount” command doesn’t show where it’s mounted (Host and Toolbox). Thanks!

I usually use a mix of the official packages site and rpmfind in order to find packages, I’m guessing rpm-ostree doesn’t have it because in general layering too much isn’t super encouraged.

gvfs itself is mounted under $XDG_RUNTIME_DIR/gvfs (where XDG_RUNTIME_DIR usually is /run/user/1000, or maybe with another UID), and all the other stuff goes under. So TL;DR, check in one of the subfolders of /run/user/1000/gvfs.

1 Like