FRITZ.NAS not shown in Nautilus (Fedora 31)


I have two computers. On my desktop computer is running Pop OS. On my new laptop I installed Fedora 31 some days ago.
Both are using GNOME als DE with Nautilus as file manager.
But on Fedora I can not see my Fritz NAS. When I type in smb://fritz.nas in Nautilus I get this error:

The packages cifs-utils and samba are installed.

Can somebody help me please?

Best regards

Hi.  Did you tried to backup a Fedora config, then copy a Pop config to Fedora (/etc samba or smb)?

yes, I tried it yesterday in the evening. But I cannot find smb.conf on Pop OS and the folder etc/samba doesn´t also exist.

# none at all within Pop?
find / -type f -name smb.conf  2>/dev/null

Thank you.
But this command end with no results on my Pop OS…

@on2082, I was able to reproduce this behaviour. Too bad FritzOS doesn’t offer an NFS share.

I think the problem could be the firewall. Maybe that has been punched open in PopOS and remains closed for samba in Fedora. Have you checked the firewall in this case?

Were you able to mount from command line?
something like

sudo mkdir /nas
sudo mount -t cifs -o user=fritzusername,uid=1000 //fritz.nas /nas

Nautilus is a pain when it comes to browsing samba shares, see [1]

[1] Zugriff auf Netzwerkverzeichnisse mit Nautilus |

I have installed a firewall-backend now and set samba permanent to allow. But in Nautilus it doesn´t work.

Also your command does not show the NAS on I always get
mount error(22): Invalid argument

I tried it with: // and …


I never had any problems to connect my NAS on Fritz.Box in Nautilus with other Distributions.

One step closer! I found this article and added

client min protocol = NT1

in file smb.conf

After the login dialog now I can see the content of the drive but cannot open it: “File not found”

On my other computer (Pop OS) there is no problem with this files.

I noticed the only installed packages refering to samba on Pop OS are libwbclient0 and samba-libs.
No samba, samba-common, …

Amazing error message from mount. Maybe check log files to see which one is the invalid argument.

I checked the log files and found:

CIFS VFS: cifs_mount failed w/return code = -2


No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.

Try adding
vers=3.0,sec=ntlmssp or vers=2.1 in command line.

1 Like

Hello again,

yesterday (or today in the night) I was able to connect to my NAS (without the possibility to open files).
In this morning my bookmark to the Fritz-NAS was gone and I had to relogin to the NAS.
So i gave up and installed Ubuntu again.
I can remember on my old laptop with Fedora 28 I also couldn’t connect to Fritz.Nas.

Thank you for your help and spending your time to my problem. I really appreciate it.

Ubuntu is not really my first choise. But I need to connect to my NAS on Maybe I am back to Fedora in future and take a look at this again to see if it works now

Best regards from germany :slight_smile:

1 Like

Maybe you had move on quickly and it seems unnecesary to run Ubuntu if you don’t want to.
I am sure we can fix that issue by fiddling around with a mount command in your /etc/fstab and once mounting is fixed there, Nautilus will always ‘see’ it.

It seems that mDNS is not working great in that combination and you can’t use the shortcut instead of the IP!

A very quick search returned to guides, especially for a Fedora client connecting to SMB shares of a Fritzbox.

(@Community, I am sorry this is in German):

If I was you I would install Fedora 31 in a virtual machine, and test it from there. Once you get it working, you can install Fedora back onto your laptop.

I tried the IP address from the Fritzbox instead of the But without success. I like Fedora, really. But I spent 3 evenings/night for trying to connect my Fritzbox. My little finger now hurts from sliding on the mousepad all whole time… And my wife was sitting alone in the living room.
With Ubuntu it works out of the box. No configuration nessesary.
But as you said, I will keep an eye on Fedora :slight_smile:

Short feedback:

I found some time to test it again on Live-USB-Version with Fedora 31.
With the fresh loaded iso-image I only had to add client max protocol = NT1 (or was it min instead of max? Cannot remember)
No changes to firewall needed. But after installing Fedora 31 to disk and performing a full update this was not working anymore.
So I finally tried the fstab-method (see link above from @florian )
I added this to my fstab:
// /mnt/FritzBox cifs credentials=/home/otto/.smbcredentials,auto,defaults,uid=1000,gid=1000,vers=1.0 0 0

Without vers=1.0 it didn´t work, so I added this (stand March 2020)

In .smbcredentials I had to set the real user of the Fritzbox, not ftpuser (see user in Fritzbox settings)

In addition I choosed /mnt/FritzBox instead of /media/FritzBox (with /mnt you will not see the device in Nautilus. That´s fine because I only set a bookmark to it)

Now the Fritz-NAS is available from startup the system. But it slows down the start of my laptop for some seconds.