(Solved) - Nextcloud Flatpak - Unable to open user interface after first run

Wondering if anyone else else is using the Nextcloud sync client flatpak and is unable to open the client interface after the first run.

The sync is working correctly but I am unable to modify the folders I want to sync :frowning: .

I have also installed https://extensions.gnome.org/extension/615/appindicator-support/ to see if the Status Indicator is present but that is not the case

Thanks in advance for your help!

13/05/19

Small update:

- https://extensions.gnome.org/extension/615/appindicator-support/ - is NOT showing the icon in the tray
- https://extensions.gnome.org/extension/1497/topicons-redux/ (which I prefer because of the prettier config menu :)) or https://extensions.gnome.org/extension/1031/topicons/ - are showing the icon in the tray!

Scrap that, for some reason the icon would disappear after the screen lock kicks in. I have opted for having the UI always visible. Just add these arguments: --env=QT_QPA_PLATFORM=wayland --socket=wayland to the existing Exec line in ~/.config/autostart/org.nextcloud.Nextcloud.desktop .

In my case it looks like this:

Exec=/usr/bin/flatpak run --env=QT_QPA_PLATFORM=wayland --socket=wayland --branch=stable --arch=x86_64 --command=nextcloud org.nextcloud.Nextcloud

I am able to open the client interface more than once… at least without connecting to a server (I don’t have one to connect to).

I installed the org.nexcloud.Nextcloud flatpak and ran is using the following command:

flatpak run org.nextcloud.Nextcloud.

The setup wizard popped up. I used escape to close both the setup splash and the general settings tab. I then tried to run it again with the same command. I was warned that the app was already running and the general settings tab came back up.

One option for you might be to run ps -ef|grep cloud and find the two pids listed there. I find that if you kill the second pid in the list it will stop the service and you can run the flatpak again to see if the windows come back. This will stop any sync process as well.

@hreidmar Thanks for helping!

Would you be able to register a free account here https://cloud.operationtulip.com/apps/registration/ and try with a server configured please?

I can still re-open the window. I don’t have a tray so I have to run from the command line. Not sure if thats how you’re doing it. My test processes follows:

  1. I created a dummy account and added it to the client.
  2. The folder syncd.
  3. I closed the window using the escape key
  4. I ran flatpak run org.nextcloud.Nextcloud
  5. The window opened to add new servers and what not.
  6. Clicked the connection to operationtulip
  7. Saw Documents and Photos listed.

I have tried launching from the icon and see that the nextcloud process is there (sync works).
If I launch it from the command line the process is also there but there is (still) no UI.

From the command line I see these errors tho:

flatpak run org.nextcloud.Nextcloud
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
Gtk-Message: 10:18:41.360: Failed to load module "canberra-gtk-module"
Gtk-Message: 10:18:41.360: Failed to load module "canberra-gtk-module"
libGL error: MESA-LOADER: failed to retrieve device information
libGL error: Version 4 or later of flush extension not found
libGL error: failed to load driver: i915

Do you also get them?

I only get the last 3 libgl errors.

Perhaps you are running Xorg instead of Wayland. I tried with Xorg and still no joy.

I have found a similar issue on the Flathub Issue tracker:

https://github.com/flathub/org.nextcloud.Nextcloud/issues/17

Many thanks for sticking with me.

Nope I’m on silver blue 30 using sway wm which is a Wayland tiling compositor.