Can't get autostart of Nextcloud working

I have this .desktop file to start Nextcloud automatically on login (named ~/.config/autostart/Nextcloud.desktop):

[Desktop Entry]
Name=Nextcloud
GenericName=File Synchronizer
Exec=/usr/bin/flatpak run com.nextcloud.desktopclient.nextcloud
Terminal=false
Icon=nextcloud
Categories=Network
Type=Application
StartupNotify=false
X-GNOME-Autostart-enabled=true
X-GNOME-Autostart-delay=3

I just recently changed the name of the program, because it changed its name in Flathub, but other than that I’ve used this and it’s worked for 6 months or so.

Now, on login nothing seems to happen.

With Wayland, where can I look for possible background errors? There’s obviously no .xession-errors, and my web searching has not turned up an alternative for the Wayland version of Gnome-Shell.

I use the original .desktop file and autostart seems working for me.

My exec looks like this:

Exec=/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=nextcloud com.nextcloud.desktopclient.nextcloud

1 Like

Where is that original .desktop file from? The only one I see created by the application is at ~/.var/app/com.nextcloud.desktopclient.nextcloud/config/autostart/Nextcloud.desktop, and looks like this:

[Desktop Entry]
Name=Nextcloud
GenericName=File Synchronizer
Exec=/app/bin/nextcloud
Terminal=false
Icon=nextcloud
Categories=Network
Type=Application
StartupNotify=false
X-GNOME-Autostart-enabled=true

Are you using the Flatpak from flathub.org or is there another one that might work better?

There is the .desktop from the actual Flatpak at /var/lib/flatpak/app/com.nextcloud.desktopclient.nextcloud/current/active/files/share/applications/com.nextcloud.desktopclient.nextcloud.desktop, but this just says Exec=nextcloud. I’ll note this doesn’t work anymore either. I guess I better go to Flathub with this issue as there seems to be some general issue with launching Nextcloud after the name change.

Alright, apparently there was already https://github.com/flathub/com.nextcloud.desktopclient.nextcloud/issues/18 about this.

I also created https://github.com/flathub/com.nextcloud.desktopclient.nextcloud/issues/20 as I can’t launch the application manually from the icon either (only via command line).

I think I do something different compared to you. I added Nextcloud to autostart by:

“Gnome Tweaks” > “Startup Applications” > “+”

I guess Tweaks creates its own .desktop file this way?

This is my .config/autostart/com.nextcloud.desktopclient.nextcloud.desktop content:
https://paste.centos.org/view/70c1d6d8

I guess Tweaks takes the desktop file from /var/lib/flatpak/... and modifies the Exec to do the call via flatpak.

Anyway, I rolled back to the last version of org.nextcloud.Nextcloud and will just use that until the issues in those GitHub issues has been addressed.

1 Like