Nextcloud Client Systrayicon and Autostart

Good morning everyone,
I have a question about the Nextcloud client which unfortunately does not generate a systrayicon when installed via flatpak in fedora35 and 36beta.
is this due to sandboxing by flatpack.
In the client the hook for autostart after login is set, only the client does not start and no running task is shown.
If I add the autostart manually via Gnome Optimization, the client starts but there is also no systrayicon.
The Deb Vaviante in the UbuntuLTS variants works in this case without problems .
I do not know what the reason can be.

I would be happy about possible solutions.
Many greetings from Vienna

GNOME doesn’t have system tray by default, you need to install an extension for that.

1 Like

I have installed this extension.
the Synology Drive Client is also displayed

May be a flatpak-specific issue. I’m running the nextcloud-client from the repo (rpm) and I can see and use the icon properly.

1 Like

This is also my guess that this is due to the sandboxing of the flatpak liegt.

Have you looked at gnome tweaks or the gnome-extension-app. In extensions there is an option to display a list of running windows on the bottom bar of the screen

1 Like

Maybe install


from flathub and check whether nextcloud has all the required permissions

1 Like

Feedback from the front.
I switched to the RPM version on one system but experienced no change.
All three variants of Fedora35 and 36 show no tray icon in the SysTray bar.
The clients themselves work and synchronize the default paths of the drives.

Under Ubuntu20.4.4LTS, Ubuntu22.4 and ZorinOS16 they are present no matter if installed from flat or as deb.

I’m a bit confused about what this is.
Attached is a photo.

Feedback again.
Tray Icons Reload shows no function.
The extension AppIndicator/KStatusNotifierItem support for GNOME Shell brings remedy.
Both versions work again.

Thanks for your help

1 Like

That’s the one I use, haven’t experienced any problems so far.

1 Like