Software Center shows error but Terminal does not

Hi everyone. I was checking for updates through GNOME Software center, and it gave me this error

failed to parse public key for /var/cache/PackageKit/36/metadata/protonvpn-fedora-stable-36-x86_64/public_key.asc

I added ProtonVPN repo couple weeks back to install ProtonVPN. Right now it seems like their repo is having some issue with the public key. Anyways, I tried doing the updates through Terminal, using
sudo dnf upgrade --refresh and all worked as normal, it checked all the repos, came back with some kernel upgrades and finished everything. Dependencies resolved, Nothing to do. Complete! I am wondering why it did not show any errors when it was syncing the metadata with ProtonVPN repo?

Can someone please explain me this? I am still confused as to why Failed to parse public key is not seen as error in Terminal and I can still update Metadata to the present second and do system upgrades as soon as they go live.

The quick explanation could be: in the terminal you use DNF, whereas GNOME Software is not a frontend to DNF, but it uses another piece of software under the hood (packagekit).

1 Like

With dnf you can use the --refresh option to update the repo metadata cache at the beginning of the transaction.

With gnome software you do not have that option within the gui, though you can (from the CLI) use pkcon refresh or pkcon refresh force to update the packagekit metadata immediately. Following that the gui will see the up-to-date metadata.