Sudo pkcon refresh force - stuck waiting in que for repository

Every time I turn on my Dell with F35 (still i know) i opn my terminal and update using

sudo pkcon refresh force and
sudo dnf update --refresh

then restart. Today It has the normal refreshing cace bar completed but then moved down to waiting in que and has the progress bar with the indicator bouncing back and fourth. its never done thi before. Is anyone familiar with this pr can explain whats gpong on?

You are mixing two update methods.
The pkcon refresh updates the cache for gnome-software, but has nothing to do with dnf.
The dnf update --refresh updates the dnf cache before doing the update.

While this certainly should keep both cache records in sync the first is not necessary for performing the second.

Please try halting the one that is stuck then redoing with just the dnf command. Dnf does not have the same progress bar.

Also, I wonder if this may be related to drive space. Please run df -h and look at the space available in /. If that is over 80 to 90% used then it may impact updates.

1 Like

so that came back and the / is on the right side correct? it eas the only one i found with just the /. it said 23%

since the creation of this article i restarted computer adn tried pkcon again and it worked. However i would still like to know the daily updates for CLI each day before the restart and work begins.

You can still do what you were doing. If that is your preferred method then go for it.

I only pointed out that with those 2 commands they are not directly related. In fact it causes download of the repo metadata twice.

The hang probably had something to do with a network issue that was not properly handled by a time-out and retry within the pkcon command

thank you that makes alot more sense.

AFAIK sudo is not needed for pkcon.

So what CLI commands do you guys use when opening up to begin a session? Want to make sure I’m not missing one.

Personally I only use dnf upgrade or dnf upgrade --refresh and look at what is being updated before I tell it yes. I have had some problems with packagekit so I avoid the gnome-software tool and have disabled the gnome automatic update process.