Snap apps does not launch after first launch

I have installed some snap apps using

snap install <appname>

But those apps does not open with the shortcut after first launch.

When I tried sudo snap run <appname> it does open but without prior settings which make sense since the root user.

How could I make snap app shortcuts to open app consistently?

Hi @nerdyadventurer, are you still having issues with snaps? If so, which version of Fedora are you running? Which desktop environment? And which snaps?

Fedora 32 Gnome
I do not think this is specific to a specific snap. Try Install superproductivity on Linux | Snap Store for an example

That is weird, I installed your example and I installed gimp and they open fine by clicking on the icon in the app menu.

Have you tried to open it for the second time?
Have you try opening after a restart?

Yes they work after restart. Can you run the program from terminal with out the snap run. For Example:

$ superproductivity

It seems this is specific to particular application since bashtop runs fines, although superproductivity does not run

context: I did a Fedora minimal install and start building things from their according to my preference.

❯ superproductivity 
WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement

App does not open