Silverblue solution for upstream udev rules (steam-devices & OpenRGB)

I have been looking around and some flatpaks are not “perfect” because they cannot ship their udev rules as part of the flatpak.

Two that I have found are:
GitHub - ValveSoftware/steam-devices: List of devices Steam and SteamVR will want read/write permissions on, to help downstream distributions create udev rules/etc (udev rules for controllers)
Adam Honse / OpenRGB · GitLab (udev rules for controlling RGB)

Now, the main use of the former is a proprietary app that wont be included in Fedora and the latter is a niche use case. But the rules themselves dont seem all that troublesome and are probably something that should be included by default.

Since neither are in fedora, I am wondering what the correct way should be? Should they be included in systemd? Should they be rpms for the rules in Fedora?

This looks like it could be an easy usability win for these cases.


now Steam flatpak shows this :

if you don’t have steam-devices in the system.

is there a security implication or other reason for not having default steam-devices in Fedora?

1 Like

Up! Very jmportant issue, that could make Fedora adoption/usage easier.


I ran into this issue on Fedora Kinoite and was able to manually install the udev rules to “/usr/local/lib/udev/rules.d/” (after making the dirs myself). This after running sudo udevadm control --reload-rules && sudo udevadm trigger at least removed the error I was getting trying to run openRGB:

<h2>WARNING:</h2><p>One or more I2C/SMBus interfaces failed to initialize.</p><p>RGB DRAM modules and some motherboards' onboard RGB lighting will not be av
ailable without I2C/SMBus.</p><p>On Linux, this is usually because the i2c-dev module is not loaded. You must load the i2c-dev module along with the correc
t i2c driver for your motherboard. This is usually i2c-piix4 for AMD systems and i2c-i801 for Intel systems.</p><p>See <a href=''></a> for additional troubleshooting steps if you keep seeing this message.<br></p>

No luck on actually seeing devices though.

Bad news, the rules have remained the error is showing again, which aligns with the fact that no devices were still being found.

You can just overlay the steam-devices package from the rpmfusion-nonfree-steam repo that’s included with you system if you enabled third-party repos during installation. Or, you can add full rpmfusion-nonfree repository.

that’s exactly what I did

1 Like