Secondary monitor blinks using Nvidia driver if hardware acceleration is enabled and window is maximized

This is very weird, but AFAICS it’s 100% reproducible.

I have a notebook with a GTX 1650 TU117M dGPU, and a AMD Renoir iGPU. HDMI is wired to the Nvidia GPU. I am using latest Nvidia drivers (525.85.05) from RPMFusion.

If I plug a secondary monitor to the HDMI port, and maximize a browser Window (Firefox or Chrome), the secondary monitor goes dark, and starts blinking (showing its content and goging completely dark) when I move the mouse. Maximizing other windows on it has no effect. Maximizing browser windows on the primary monitor also has no effect.

Not sure if it is related, but monitors have different frequencies (primary = 144Hz , secondary = 60Hz)

I have already posted a message on Nvidia Linux forum, but I’m afraid it won’t attract too much attention.

Is there any browser configuration that I can (de)activate to try to workaround this?

UPDATE: disabling hardware acceleration on FIrefox makes the problem go away. But I was wondering if there would be a more specific setting to tinker with that would workaround only the fullscreen issue, since aside from that everything seems to work just fine.

1 Like

That’s what I would have proposed you reading the topic without the Update.

Are you still using the same xrandr config as posted here?:

The HDMI is listed just as 60Hrz, can imagine that the HD acceleration treys to switch to 144Hz and it is not able, so the black screen apeares.

Hi @ilikelinux , thks for joining!

Yes, it’s the very same setup :wink: The external monitor is a somewhat old one, and is only capable of delivering 1920x1080 @ 60Hz . What puzzles me is the fact that it only bugs at fullscreen, so there must be something special about it. A friend of mine pointed some links about unredirect + full screen (eg. this one), but it seems to be old stuff, not sure it still applies.

I guess fully disabling hardware acceleration both on Firefox and Chrome is the only viable option right now :disappointed:

Have you tried both with wayland desktop and xorg desktop to see if there is a difference?

I would suggest that this may be the iGPU interfering, and that if you were to switch to using xorg and setting the nvidia GPU as primary the problem may disappear.

Hi @computersavvy !

No, I haven’t, and based on past experiences, there is indeed a chance this would work. However, I guess I’d rather stick to Wayland with hardware optimization turned off on the browsers than the other way around (have hw optimization but be stuck with X11). But I do appreciate the suggestion! :+1:t3:

I have the same problem, but not only with browsers. Any program that tries to use hardware acceleration at full screen generates external monitor flicks

Hi @utrescu , you are right, this describes more accurately what is happening. I hope Nvidia fixes it soon. However, my post there seems to be sitting in the dust. Perhaps if you give it a bump there we have better chances… :wink:

For the record, @computersavvy suggestion of running X11 instead of Wayland seems to work.

Updated the post title to better describe the problem

I don’t know who is responsible, but after the last update of the kernel and the Nvidia driver, the external monitor blinks have been reduced drastically. Now I can maximize Firefox on the external monitor without blinks.

It is not perfect because in the past two days it has failed once. But it is something else!

That’s interesting to hear, thanks for the feedback. I am traveling right now, but will definitely give it another try when I return.

BTW the thread on NVidia developer forums attracted some attention :eyes:

For those following this issue, another update: some of the top contributors on the Nvidia forum pointed that there seems to be a bug report on the GNOME bugzilla about this (although it is not the exact same scenario). I’ve added some more info there.

It was suggested on the discussion that a specific GNOME shell extension might work around the problem, I will try it out soon and post here the results.

UPDATE: the extension works, the flickering is gone AFAICS. And the issue on GNOME bugzilla has been acknowledged, and migrated to mutter.


It seems to work in my system too. Two days with the extension and no black flicks on external monitors. (And I have forced myself to use full screen hardware acceleration whenever I could)

GPUS: Intel CoffeeLake-H GT2 [UHD Graphics 630] + NVIDIA GeForce GTX 1060 Mobile